Welcome, Guest. Please login or register.


Author Topic: Hibaelhárítás (Read 262242 times)

Offline lgb

  • EP addict
  • *
  • Posts: 3563
  • Country: hu
  • æðsta yfirmaður
    • http://lgb.hu/
Re: Hibaelhárítás
« Reply #255 on: 2013.May.24. 23:03:50 »
Quote from: Zozosoft
A 12V-ot ellenőrizd, hogy meg van-e! Ha nincs, akkor valószínűleg a TR2 jelű BC337-es tranyó szállt el. Az ok pedig lehet a C9-es elkó kiszáradása (különösen a Philips gyártmányúak hajlamosak rá).

Ok, koszi, nezem majd. Fene ezekbe az elkokba, tok hasonlo gond (elko problema miatt tranyo elszallas) mar volt egy monitoromnal es tv-nknel is. Lehet kapni normalis elkot, ami belathato idon belul nem adja meg magat? :)

U21-en mertem, ha minden igaz az egy 12V stabIC, bemeneten 16V, kimeneten 12V, tehat szerintem a kijovo 12 oke ... Gondolom az elotte allo tranyos komplexum amiben van induktivitas meg az altalad emlitett tranyo is allit elo nagyobb feszultseget amit aztan az U21 (78L12) stablizal szepen 12V-on. Kapcsrajz alapjan neztem, mert lathatoan itt all elo a 12V, vagy mashol kene neznem?
« Last Edit: 2013.May.24. 23:58:13 by lgb »

Offline lgb

  • EP addict
  • *
  • Posts: 3563
  • Country: hu
  • æðsta yfirmaður
    • http://lgb.hu/
Re: Hibaelhárítás
« Reply #256 on: 2013.May.25. 00:13:20 »
Alaplap foto

Nem mintha olyan sok EP-t lattam volna mar belulrol, de most a konkret hiban kivul szamomra erdekes a teny, hogy a CPU es kornyeken azok a szines papiros feliratok, ami kezirasnak tunik. F es AF felirattal. Az mi lehet? Foleg, mivel ez az EP talan meg szet sem volt szedve, ez volt az amit kb ujszeru allapotban vettem, es a sorozatszamos hatso papir sertetlen volt, ahol pedig ugye egy csavar van. Vagy ez a papirozgatas csak nekem uj, es lattatok mar ilyet?

Masik gepben nincsenek ilyen "cetlik", igaz az mar lathatoan volt bontva mielott en szetszedtem.
« Last Edit: 2013.May.25. 00:17:47 by lgb »

Offline Zozosoft

  • Global Moderator
  • EP addict
  • *
  • Posts: 14683
  • Country: hu
    • http://enterprise.iko.hu/
Re: Hibaelhárítás
« Reply #257 on: 2013.May.25. 00:19:03 »
Quote from: lgb
 Vagy ez a papirozgatas csak nekem uj, es lattatok mar ilyet?
Csak neked új! Pont ugyanilyet láttam már többet is. Gondolom a gyárban a MEO-nak lehetett valami jelzése.

Offline lgb

  • EP addict
  • *
  • Posts: 3563
  • Country: hu
  • æðsta yfirmaður
    • http://lgb.hu/
Re: Hibaelhárítás
« Reply #258 on: 2013.May.25. 20:02:27 »
Hat sok otletem nincs, mint irtam fentebb, +12V rendben, kapcsrajz alapjan probaltam ezt/azt mergetni de nem igazan talaltam semmit. Egyszer amugy sikerult a "fatal WP error" uzenetet is megkapnom, ilyet meg ugyse lattam :) Ami viszont erdekes, hogy "stabilan" valami anomalia latszik a kepernyon, amde gyakran az hirtelen megvaltozik, ha hozzaerek a multmeterrel valamilyen ponthoz, raadasul ugy, hogy csak az egyik merozsinorral, a masikhoz meg nem is nyultam. Nem tudom ez mire utalhat, kontakthiba is lehetne, de amugy nem tunik annak, mas fizikai behatasra nem reagal.

Masik EP jo, annak viszont szentment teljesen a billentyuzete amikor kaptam mar, lehet csinalok most ket EP-bol egyet. Bar azert sajnalom :(

Offline Zozosoft

  • Global Moderator
  • EP addict
  • *
  • Posts: 14683
  • Country: hu
    • http://enterprise.iko.hu/
Re: Hibaelhárítás
« Reply #259 on: 2013.May.25. 20:07:53 »
EXOS 2.4 "BEEP" tesztjét nem próbáltad még?

Offline Zozosoft

  • Global Moderator
  • EP addict
  • *
  • Posts: 14683
  • Country: hu
    • http://enterprise.iko.hu/
Re: Hibaelhárítás
« Reply #260 on: 2013.May.25. 20:27:04 »
Quote from: Zozosoft
EXOS 2.4 "BEEP" tesztjét nem próbáltad még?
Ami ennek a tesztnek a beépített verziója.
Itt a hibakeresés topic elején írtam is, hogy több döglött Z80-at is találtam ezzel, ráadásul úgy néz ki, hogy a te procid is abban a gyárban készülhetett.

Offline lgb

  • EP addict
  • *
  • Posts: 3563
  • Country: hu
  • æðsta yfirmaður
    • http://lgb.hu/
Re: Hibaelhárítás
« Reply #261 on: 2013.May.25. 21:05:39 »
Sajna javareszt inkabb emulatoron nyomultam csak eddig, szoval valodi gepekben a gyari EXOS 2.1 van, EPROM egetom meg jelenleg nincs (EPROM lenne meg itt valahol kb fel kg - szo szerint! -, csak az ugye nem segit most). Amugy nem tudom az mit segitene, ugy tunik, hogy kb 10 inditasi kiserletbol 1x latszik vmi (memoriatesztig eljut, de pl EXOS helyett EYOS latszott 1x meg egyeb anomaliak az ERROR mellett), ha meg odaig sem jut el, akkor a beep teszt sem segitene. Vagy rosszul gondolom? Vagy ehhez van koze annak, amit irtal, hogy van egy logikai bukfenc miszerint hasznalja az FF szegments (CALL miatt), mielott ellenorizne? Csak tippelek, hogy erre gondoltal.

Offline lgb

  • EP addict
  • *
  • Posts: 3563
  • Country: hu
  • æðsta yfirmaður
    • http://lgb.hu/
Re: Hibaelhárítás
« Reply #262 on: 2013.May.25. 21:22:23 »
Na egyre furabb dolgok tortennek! Megint megprobaltam bekapcsolni, es most kb 10 tesztbol mindegyik jo, nincs memoriahiba, nem szall el kozben stb (most eppen billentyuzet nincs bekotve tehat tovabb nem neztem). Viszont az Enterprise feliratbol az I betu egy resze mindig pontosan ugyanugy hianyzik, amugy normalis! Most jon a durva: kicsereltem masik basic cartridgre, akkor az felirat meg erdekesebb pl az E betu az 8-asnak tunik, es meg tobb helyen van hiba. Ha egyaltalan nincs cartridge radugva akkor az egyes betuk nem is egyszinuek. Ami erdekes, hogy konzisztensnek tunik, tobbszor cserelgettem, es a harom eset (egyik v masik cartridge, illetve anelkul) pontosan ugyanugy hibas Enterprise feliratot produkal (marmint mindegyik esetre a sajat erdekesseget)! Ja, es az EXOS 2.1 memtestje egyik esetben sem talal hibat ahogy latom. Ez mi a fene lehet? A masik EP mindharom esetre ugyanolyan, hibatlan feliratot produkal (ahogy lennie is kene).

Offline Zozosoft

  • Global Moderator
  • EP addict
  • *
  • Posts: 14683
  • Country: hu
    • http://enterprise.iko.hu/
Re: Hibaelhárítás
« Reply #263 on: 2013.May.25. 21:26:17 »
Pont az a lényege a beep tesztnek, hogy a program futásához egyáltalán RAM-ot, így hibás alaplapi RAM-mal is tud visszajelzést adni. Ezekben az esetekben az eredeti EXOS RAM teszt leginkább el se indul (a CALL miatt), ilyenkor csak valami véletlenszerű szemét látszik a képernyőn, amit a bekapcsoláskor véletlenszerűen* feltöltődött memória és Nick regiszterek generálnak.

* gondolom az alkatrészek szórásától függ, de egy adott gépen általában minden bekapcsoláskor az adott gépre jellemző minta alakul ki. Szokott olyan lenni amin függőleges fekete-fehér sávok vannak, van amelyiken valami piros szmötyi látszik, és olyan is ahol keretszínű az egész kép.

Offline Zozosoft

  • Global Moderator
  • EP addict
  • *
  • Posts: 14683
  • Country: hu
    • http://enterprise.iko.hu/
Re: Hibaelhárítás
« Reply #264 on: 2013.May.25. 21:33:08 »
Quote from: lgb
Na egyre furabb dolgok tortennek!
A +5V-os tápokat is ellenőrizted?
Ha azok rendben vannak, akkor első körben Z80-ra tippelnék (10 perc alatt ki lehet cserélni :-) )
De egy Advanced memória teszt a 2.4-ből is érdekes lehet, címvezeték és frissítési hibák jó részét nem veszi észre az eredeti teszt.

Offline lgb

  • EP addict
  • *
  • Posts: 3563
  • Country: hu
  • æðsta yfirmaður
    • http://lgb.hu/
Re: Hibaelhárítás
« Reply #265 on: 2013.May.25. 22:06:40 »
Quote from: Zozosoft
A +5V-os tápokat is ellenőrizted?
Ha azok rendben vannak, akkor első körben Z80-ra tippelnék (10 perc alatt ki lehet cserélni :-) )
De egy Advanced memória teszt a 2.4-ből is érdekes lehet, címvezeték és frissítési hibák jó részét nem veszi észre az eredeti teszt.

5V is jonak tunik, hibahataron belul (4.9x ...). Azt aruld el, hogy cserelned ki, oszinten nekem csak az az otletem van (amit mar csinaltam mas helyzetekben, csak mindig faj a szivem felaldozni egy alkatreszt ami meg talan jo amugy), hogy levagom a Z80 labait, aztan egyenkent kiforrasztom a maradvanyokat, utana meg ugye foglalatot tesz az ember nyilvan, es abba egy masik Z80-at (mondjuk egy Z80A meg Z80B is van valahol elfekvoben ...). Van ennel valami jobb megoldas, ami sima mezei egy szem pakaval elvegezheto? Nekem sajnos az onfelszivo femharisnya, plusz onelszivo dugattyus ize (mi a hivatalos neve ...) eroteljes hasznalataval se sikerult sose kioperalni IC-t mas modszerrel, de lehet en vagyok a bena.

Ha egyszer majd letrejon az uj helyen a klub, ahova en is eltalalnek, esetleg kerhetnek toled egy EXOS2.4 egetest, ha adok EPROM-ot (felteve ha addig nem szerzek egy EPROM egetot)? Vegulis a turbo nem aktualis most elsore, sot EXDOS kartyam sincs, szoval nem zavar az emlitett bug :)
« Last Edit: 2013.May.25. 22:10:19 by lgb »

Offline Zozosoft

  • Global Moderator
  • EP addict
  • *
  • Posts: 14683
  • Country: hu
    • http://enterprise.iko.hu/
Re: Hibaelhárítás
« Reply #266 on: 2013.May.25. 22:36:20 »
Egyszerű páka még kevés :oops: Kell egy kézi ónszippantó meg egy hőlégfúvó (egyszerű barkácsáruházas darab, 300 fokot tudjon).
Végig megyek az összes lábon az ónszippantó+páka kombinációval, ezzel kb 95%-ban meg van a dolog, de ott van az, hogy pár láb oda van tapadva a lukgalván oldalához, és így nem mozdul az IC, vagy ha mégis akkor feltépi a NYÁK fóliát...
Ezért itt jön a hőlégfúvó, túloldalról óvatosan melegíteni a kérdéses területet, olyan 5-6 centi távolról, kb 7-8 másodperc kell, túloldalról fogni IC kiszedő csipesszel, és amikor látszik, hogy olvad az ón, akkor kihúzni az IC-t.
Ha nincs kéznél IC csipesz, lapos csavarhúzóval alányúlva is lehet, itt is előre bekészíteni, és olvadásnál nyomni. Kisebb IC kijön egyből, Z80 méretűnél úgy szoktam, hogy amikor olvad az ón, akkor hőlégfúvó kikapcsol, hogy ne égjen szét az alaplap, közben csavarhúzóval kifeszíteni az egyik feléről, kb míg a lábak fele kijön, közben kezd megdermedni az ón, ekkor átrakni a csavarhúzót a másik felére, majd újabb pár másodpercnyi melegítés a maradék lábakra, olvadásnál feszítve kifelé és már ki is pottyant az IC.
Ezután már csak esetleg pár nem tökéletesen tiszta lukat kell ki ónszippantani, és már mehet is be a foglalat.

Mondjuk egy satu se árt a dologhoz, vagy valaki aki fogja az alaplapot :-)

EPROM-ot persze tudok égetni.

Offline Zozosoft

  • Global Moderator
  • EP addict
  • *
  • Posts: 14683
  • Country: hu
    • http://enterprise.iko.hu/
Re: Hibaelhárítás
« Reply #267 on: 2014.January.03. 13:34:23 »
Alaplapi tápcsatlakozót kerestem, ami mivel azonos a Spectruméval, megnéztem a WoS-on. Azt írják:
Quote
inner diameter is 2.5mm
Na ezzel lehet jól pórul járni, mert nem megy bele a tápdugó :evil:
A helyes adat: 2.1mm!

Lomexben: TÁP DC ANYA 5.5/2.1/9.5mm DCS-5521-5 (G-S) NYÁK 90° [43-07-67]

Offline szipucsu

  • Global Moderator
  • EP addict
  • *
  • Posts: 9842
  • Country: hu
    • Támogató Támogató
    • Webnyelv.hu - Tanuljunk nyelveket!
Re: Hibaelhárítás
« Reply #268 on: 2014.January.08. 13:06:46 »
Ha magnóról nem tölt be néhány fájlt a gép, az mitől lehet? A magnófejet is állítgattam, megtisztítottam, így sem. A file nevet megtalálja, de aztán CRC hibával leáll. A kazetta elején több program volt, amit betöltött. Utána lett a gond. A magnófejet átállítottam, így betöltött kettő újabbat, de az azutániakkal nem boldogul.

Egy idő után magnóról töltésnél elkezdett mászni a kép. Lehet, hogy kevés feszültséget kap a magnó, vagy a gép, és ez a gond?

Régebben bejött néha, ha a turbó kiegészítés is be volt töltve. Majd kipróbálom így is.
100 SOUND SOURCE 2,STYLE 128,PITCH 25.2,SYNC 1
110 SOUND PITCH 25,SYNC 1
120 ! Videos

Offline geco

  • EP addict
  • *
  • Posts: 7014
  • Country: hu
    • Támogató Támogató
Re: Hibaelhárítás
« Reply #269 on: 2014.January.08. 15:09:24 »
Quote from: szipucsu
Ha magnóról nem tölt be néhány fájlt a gép, az mitől lehet? A magnófejet is állítgattam, megtisztítottam, így sem. A file nevet megtalálja, de aztán CRC hibával leáll. A kazetta elején több program volt, amit betöltött. Utána lett a gond. A magnófejet átállítottam, így betöltött kettő újabbat, de az azutániakkal nem boldogul.

Egy idő után magnóról töltésnél elkezdett mászni a kép. Lehet, hogy kevés feszültséget kap a magnó, vagy a gép, és ez a gond?

Régebben bejött néha, ha a turbó kiegészítés is be volt töltve. Majd kipróbálom így is.
Szerintem az lehet, hogy a BAM Turbocpy-val lett másolva ( a régebbivel, ami csak 60 Kb körül tudott másolni), és magasabb, 3000 bauddal, az ilyen programjaimat pár évig ette az EP turbó nélkül, de utána szinte csak turbóval tudtam betölteni. Gondolom a szalag nyúlt meg egy picit.