Welcome, Guest. Please login or register.


Author Topic: SCART/Peritel Cable issue. (Read 1416 times)

Offline JihemB

  • Newbie
  • Posts: 5
  • Country: fr
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 60.0 Firefox 60.0
    • View Profile
SCART/Peritel Cable issue.
« on: 2018.June.24. 10:01:39 »
Hi Enterprise Forever forum members.

I just enter my very first Enterprise computer in my 8 bit collection and I would like to have a nice RGB SCART output for it.

I ordered such a cable from a Spanish website (RetroCables) but it doesn't work on two of my TV sets : My old CRT Philips and by Panasonic Plasma. In both cases I have a grey screen on which I can barely see the b&w image of the computer. I think this could be a pin 8 or 16 (switching) issue but the guy from the website claims "the cable was fully tested before shipping".

So my question are :
 - How can I sort out which part (cable or Enterprise connector) is faulty ?
 - Is there another place where I can order a trusted SCART cable ?

Thanks in advance for your help.

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13022
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 60.0 Firefox 60.0
    • View Profile
    • http://enterprise.iko.hu/
Re: SCART/Peritel Cable issue.
« Reply #1 on: 2018.June.24. 10:29:29 »
Welcome here!

With RF cable your machine working?

It is a common motherboard failure when the internal 12V circuit broken. It is for the video circuits, and also it is the 12V output on monitor connector for the Scart switch signal.

Then first check 12V are present on the Scart plug?

Connector pinout and the commonly used Scart cable wiring at bottom of this page.

I bought cables from Spain and it is worked for me. I will check which resistors used.

It is a more than 30 years experience: some TVs need to play with the resistors values.

Offline Dr.OG

  • EP fan
  • *
  • Posts: 122
  • Country: hu
  • dr.
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 67.0.3396.87 Chrome 67.0.3396.87
    • View Profile
Re: SCART/Peritel Cable issue.
« Reply #2 on: 2018.June.24. 10:37:26 »
Take a look to the last picture on the following site (recommended in the previos post as well):

http://enterprise.iko.hu/pinouts.htm

If 12V is present on pin B6 of EP128, perhaps the resistors are missing from your cable (you can measure the resistance between the corresponding pins of the connectors with a multimeter, or simply disassemble the housing of the connectors), this may cause similar symptoms. In this case complete the cable adding the necessary resistors (I recommend to use 330 instead of 100 Ohms in cases of R, G, B and CS signals), they will comfortably fit into the housing of the SCART connector.

Another topic related to appropriate resistor values:
https://enterpriseforever.com/hardware/resistor-values-for-scart-cable/

Best regards: Gábor
« Last Edit: 2018.June.24. 10:44:15 by Dr.OG »
ÉN ekelek, TE keregsz, Ő gyeleg,
MI ákolunk, TI vornyáztok, ŐK lendeznek.

Offline JihemB

  • Newbie
  • Posts: 5
  • Country: fr
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 67.0.3396.87 Chrome 67.0.3396.87
    • View Profile
Re: SCART/Peritel Cable issue.
« Reply #3 on: 2018.June.25. 15:12:51 »
Hi.
Thanks for your suggestions.

Yes the RF out is working.

I'll have a look at the B6 pinout of my Enterprise first (what is the ground pinout, B2 ?) to check for 12V, then I'll have a look at the SCART cable pinout and check for resistances included.

Best Regards.

JihemB

Offline Dr.OG

  • EP fan
  • *
  • Posts: 122
  • Country: hu
  • dr.
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 67.0.3396.87 Chrome 67.0.3396.87
    • View Profile
Re: SCART/Peritel Cable issue.
« Reply #4 on: 2018.June.25. 15:20:49 »
...
I'll have a look at the B6 pinout of my Enterprise first (what is the ground pinout, B2 ?) to check for 12V, then I'll have a look at the SCART cable pinout and check for resistances included.
...
Yes. A2 and B2 are both GND/0V pins.
ÉN ekelek, TE keregsz, Ő gyeleg,
MI ákolunk, TI vornyáztok, ŐK lendeznek.

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13022
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Firefox 56.0 Firefox 56.0
    • View Profile
    • http://enterprise.iko.hu/
Re: SCART/Peritel Cable issue.
« Reply #5 on: 2018.June.26. 20:36:04 »
I measured my Spanish cable: it is as the well know schematic. 100 Ohms on colors and sync, 12V to pin 8, and 470 Ohm at pin 8-16.

Offline JihemB

  • Newbie
  • Posts: 5
  • Country: fr
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 61.0 Firefox 61.0
    • View Profile
Re: SCART/Peritel Cable issue.
« Reply #6 on: 2018.September.01. 12:26:18 »
Hi guys.

I didn't attend the forum for a while, sorry.

My problem with the scart lead is now fixed. I was actually the scart socket part of the lead had a problem. It seems that were is was incorrectly assembled so the scart pins was to deep comparing with the exterior socket shield. As a result, when connected to the TV set the pins weren't correctly with the TV pin holes so signal wasn't transmitted...

Thanks for your help.

Offline neurox

  • Newbie
  • Posts: 3
  • Country: dk
  • OS:
  • Linux (Fedora)) Linux (Fedora))
  • Browser:
  • Chrome 69.0.3497.81 Chrome 69.0.3497.81
    • View Profile
Re: SCART/Peritel Cable issue.
« Reply #7 on: 2018.September.09. 00:15:35 »
My problem with the scart lead is now fixed. I was actually the scart socket part of the lead had a problem. It seems that were is was incorrectly assembled so the scart pins was to deep comparing with the exterior socket shield. As a result, when connected to the TV set the pins weren't correctly with the TV pin holes so signal wasn't transmitted...

Also waiting for an RGB cable from RetroCables. I'll make sure to check if the SCART connector is correctly assembled.

Offline neurox

  • Newbie
  • Posts: 3
  • Country: dk
  • OS:
  • Linux (Fedora)) Linux (Fedora))
  • Browser:
  • Chrome 69.0.3497.100 Chrome 69.0.3497.100
    • View Profile
Re: SCART/Peritel Cable issue.
« Reply #8 on: 2018.September.26. 09:47:46 »
Also waiting for an RGB cable from RetroCables. I'll make sure to check if the SCART connector is correctly assembled.

Cable arrived. Looks good, although the cinch connector house looks like it came from a kid's 3D printer! :D Meanwhile, my only working Enterprise died, so it will be a while before I can - hopefully - test the cable.