Welcome, Guest. Please login or register.


Author Topic: EXDOS (Read 14775 times)

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13464
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 28.0 Firefox 28.0
    • View Profile
    • http://enterprise.iko.hu/
Re: EXDOS
« Reply #75 on: 2014.May.04. 17:08:51 »
Ok, here are the current versions.
« Last Edit: 2014.May.10. 08:47:27 by szipucsu »

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13464
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 28.0 Firefox 28.0
    • View Profile
    • http://enterprise.iko.hu/
Re: EXDOS
« Reply #76 on: 2014.May.07. 21:14:37 »
Gustavo!
There is IS-DOS Spanish version, extracted from your old modified EXDOS-ISDOS ROM.
It is ok?

This will be built in to the new 1.4 Spanish ROM.

Offline gflorez

  • EP addict
  • *
  • Posts: 2622
  • Country: es
  • OS:
  • Unknown Unknown
  • Browser:
  • Firefox 29.0 Firefox 29.0
    • View Profile
Re: EXDOS
« Reply #77 on: 2014.May.07. 22:02:28 »
 Do we have room for more explicit messages too?

If  so let me add some verbs and complements to the sentences.

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13464
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 28.0 Firefox 28.0
    • View Profile
    • http://enterprise.iko.hu/
Re: EXDOS
« Reply #78 on: 2014.May.07. 22:07:44 »
Quote from: gflorez
Do we have room for more explicit messages too?
Currently no :-( It also needs to be disassembled.
« Last Edit: 2014.May.10. 08:49:07 by szipucsu »

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13464
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 28.0 Firefox 28.0
    • View Profile
    • http://enterprise.iko.hu/
Re: EXDOS
« Reply #79 on: 2014.May.07. 22:12:45 »
I found one missing translation, at about 1300h, it is part of the MODE command, when writing 40 or 80 column screen, the secondary language message left Hungarian.

Offline gflorez

  • EP addict
  • *
  • Posts: 2622
  • Country: es
  • OS:
  • Unknown Unknown
  • Browser:
  • Firefox 29.0 Firefox 29.0
    • View Profile
Re: EXDOS
« Reply #80 on: 2014.May.07. 22:35:13 »
Ok, not a hard work. I`ll rearange some lines and fix that error. Tomorrow morning, as I haven`t a PC now.

Offline gflorez

  • EP addict
  • *
  • Posts: 2622
  • Country: es
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 28.0 Firefox 28.0
    • View Profile
Re: EXDOS
« Reply #81 on: 2014.May.07. 23:14:43 »
I can't wait till tomorrow.... Only two modifications possible.... and made.

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13464
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 29.0 Firefox 29.0
    • View Profile
    • http://enterprise.iko.hu/
Re: EXDOS
« Reply #82 on: 2014.May.18. 11:21:06 »
The most frustrating bug when using EXDOS with EP64:
10609-0

The EXDOS manual talking about it:
Quote
If you are using an Enterprise 64 with EXOS version 2.0

 - You will not be able to use the 'null' filename to load the file
  'START' from disk (see appendix E). If you press Fkey 1 [START]
  from BASIC, EXDOS will think that you are trying to load a file
  from the RAMDISK.

I debbuged the problem: the bug is in the EXOS 2.0 device handler interface.
The EXOS string used at channel open have a 4 parts all are optional
- device name
- "-" character
- unit number
- file name
Some valid examples:
"TAPE-2:GAME.BAS"
"DISK1:GAME.BAS"
"2:GAME.BAS"
"B:GAME.BAS"
"TAPE2:"
"GAME.BAS"
""
If no device name definied then the Default Device used. If no unit number definied then 0 unit number used.
When using EXDOS, the Default Device are the DISK: and DISK0: means the current drive. DISK1 to DISK26 the drives from A to Z.
When using just filename for example "GAME.BAS", then DISK device used, and 0 unit number passed by the EXOS to DISK device, then using default drive for load GAME.BAS.

It is a special function of the EXDOS when null filename used for loading then using "START" filename. This is for IS-BASIC, when pressing F1 key as in tape system, it is enter command START. It is use "" filename for loading.
The problem about it in the EXOS 2.0: when using null EXOS string then the Default Device right used, but forgot to use 0 as default unit number. C register contains the unit number passed to device driver, at this situation contain some random data (probably the length of default device name string), it is =5. Then the DISK device think need to use 5. disk drive which are the E: then come the No RAM disk error, because no RAMDISK at startup.

Anyway if you create RAMDISK and put the START file to E: then the START command works :-)

If device name or unit number are definied then the right unit number passed to DISK device, for example:
LOAD "DISK:"
LOAD "DISK0:"
LOAD "0:"
LOAD "DISK-0:"
are load the START file from the default drive.
But these need a many more typing than just pressing F1 key...

The best solution are the upgrade EXOS in the machine... but todays many EP64 machines in the collections don't want to be opened.
So, I thinking add some hack to DISK device for bypassing this problem:

IF filename="" AND unitnumber=5 AND EXOS=2.0 THEN LET unitnumber=0 :-)

With this modification the START will be works on unmodified EP64! But this will generate another bug :oops:
LOAD "DISK5:" will be load START file from the default drive instead drive E: when using EXOS 2.0.
But I'm really sure nobody typed LOAD "DISK5:" command in the last 30 years :ds_icon_cheesygrin:
(LOAD "E:" will works corretly, and no problem with LOAD "DISK5:filename" commands.)
Then I think this will be acceptable compromise, the START command (just press F1 key in BASIC) are very often used, need to be working also with EXOS 2.0.

What do you think about add this modifications to EXDOS 1.4?

Offline gflorez

  • EP addict
  • *
  • Posts: 2622
  • Country: es
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 29.0 Firefox 29.0
    • View Profile
Re: EXDOS
« Reply #83 on: 2014.May.18. 23:01:55 »
I like your efforts to homogenize EXOS and EXDOS to work with every configuration. Now is a good oportunity, I think you must do it.

Offline BruceTanner

  • EP user
  • *
  • Posts: 485
  • Country: gb
  • OS:
  • Linux Linux
  • Browser:
  • Chrome 34.0.1847.114 Chrome 34.0.1847.114
    • View Profile
Re: EXDOS
« Reply #84 on: 2014.May.18. 23:08:38 »
Well deduced and described zozo :)  go for it! :smt023

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13464
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 29.0 Firefox 29.0
    • View Profile
    • http://enterprise.iko.hu/
Re: EXDOS
« Reply #85 on: 2014.May.18. 23:18:47 »
Already done :-)
This code inserted (with subrutine call) at the DISK open entry point:
Code: ZiLOG Z80 Assembler
  1.     LC778:  LD A,(0B21CH)
  2.                     CP 0B2H
  3.                     JR Z,C778END    ;EXOS 2.1+
  4.                     LD A,(DE)
  5.                     OR A
  6.                     JR NZ,C778END   ;NOT A NULL FILENAME
  7.                     LD A,C
  8.                     CP 5
  9.                     JR NZ,C778END   ;NOT A DISK5
  10.                     LD C,0                  ;0 UNIT NUMBER
  11.     C778END

Also added ISDOS to ROM, it is compressed by Epcompress (from IstvanV).
There is the first test version.

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13464
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 32.0 Firefox 32.0
    • View Profile
    • http://enterprise.iko.hu/
Re: EXDOS
« Reply #86 on: 2014.October.15. 23:53:07 »
Latest EXDOS 1.4 (near to final), big modification about EXDOS.INI search, because now need a HDD (SD) booting :-)

Search the EXDOS.INI at drives: E-F-B-A
Because possible to put something crazy to F:EXDOS.INI :-D , added feature for skip it: pressing Left SHIFT key will skip the EXDOS.INI search (like as at PC from MSDOS 5.0+ you can skip the configuration files).
At the ENTERPRISE screen press down the SHIFT and press other key, and still down the SHIFT for few moments.

At default only run one EXDOS.INI. For example it is found on F: then don't search it on floppies.
With the CTRL key possible run all EXDOS.INI files for example after the F: then also run from A: (if the first INI give back the control).

With the ALT key only the floppy drives (B-A) searched for the INI file.

The actual drive:
At the start of EXDOS.INI the drive which are contain the INI will set to the actual drive.
If one EXDOS.INI succesfully executed then the actual drive saved and will be restored at the end. For example INI runs from F: and no INI at floppy drives then the F: will be the actual drive when entering to the BASIC prompt.
If more INI files executed then the drive of the last one will be preserved.
If the INI file change the drive, for example runs from F: and change to H: and no other INIs, then the H: will be the actual.

If no any INI files (or skiped by SHIFT) then the F: will be the default actual drive if it is exist. If not exist then the A: used as default.

(Think about your PC: it is start with C: if hard disk installed. At Enterprise the F: the first hard disk drive letter (it is can be a IDE disk or SD card))
« Last Edit: 2014.October.19. 11:55:46 by Zozosoft, Reason: Replaced ROM file »

Offline lgb

  • EP addict
  • *
  • Posts: 3496
  • Country: hu
  • æðsta yfirmaður
  • OS:
  • Linux (Ubuntu) Linux (Ubuntu)
  • Browser:
  • Firefox 33.0 Firefox 33.0
    • View Profile
    • http://lgb.hu/
Re: EXDOS
« Reply #87 on: 2014.October.16. 18:08:36 »
Something odd happened here, when I tried to use this EXDOS version in JSep:

http://ep.lgb.hu/jsep/demo.new/

It uses its "default" EXDOS (it's EXDOS20.ROM by its name at least), you can start ISDOS from IS-BASIC with command ":ISDOS" with no problem (I guess it needs IS-DOS.SYS from disk, but it's on the default disk image used by the emulator), you can try it.

Now, I've just installed (onto the JSEP server so it can use it) the EXDOS version you posted here, you can try it here:

http://ep.lgb.hu/jsep/demo.new/?exdos=exdos14.rom

What I can see (from IS-BASIC again):

*** Unexpected value given.
*** BASIC data has been corrupted.

The last line repeats. Is it some kind of bug, or just bad combination of ROM images I use with my emulator?

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13464
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 33.0 Firefox 33.0
    • View Profile
    • http://enterprise.iko.hu/
Re: EXDOS
« Reply #88 on: 2014.October.19. 10:57:59 »
Yes it is a bug :oops: :oops: :oops: (Hungarian version working) I will fix it.

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13464
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 33.0 Firefox 33.0
    • View Profile
    • http://enterprise.iko.hu/
Re: EXDOS
« Reply #89 on: 2014.October.19. 11:56:52 »
Ok, fixed it, I have replaced the ROM file below.
« Last Edit: 2014.December.16. 14:12:37 by szipucsu »