Welcome, Guest. Please login or register.


Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Wolfgang

Pages: 1 [2] 3
16
Hardware / Re: Memory problem with EP128
« on: 2020.October.09. 21:28:04 »
With upper you mean video Ram...?

Sorry, I misspoke. What I mean is the memory that gets tested after the first 64kB (FC-FF), between 64kB and 128kB (F8-FB) which in fact is lower than the video RAM.;-)

17
Interface / Re: Internal memory expansion
« on: 2020.October.09. 14:25:31 »
My pcbs arrived today:
25572-0
25574-1
and everything seems to work okay. :)
25576-2
25578-3

18
Memória / Re: 512K belső RAM bővítés - II
« on: 2020.October.09. 09:04:26 »
very cool!
How did you solve the issue of wiring EXP2 to the pins on the pcb. More precisely, can you still close the computer when you use those Dupont jumper connectors?

19
Hardware / Re: Memory problem with EP128
« on: 2020.October.08. 20:57:08 »
I found an image containing ASMON here and was able to identify bit 3 (U103) as the culprit. Thanks for the great explanation!

as i remember, i use winimage:
www.winimage.com/download.htm
Thanks! I will look at this anyway, since I need to find a way to get individual files into an image file.

20
Hardware / Re: Memory problem with EP128
« on: 2020.October.08. 19:02:13 »
Sorry for reviving this old topic, but I have a similar problem. EP128 and EXOS2.4 reports upper 64KB BAD.

I have a EXDOS card with Gotek and Flashfloppy connected. I would like to use ASMON to find the bad RAM chip, but I don't know how to get ASMON.EXT into an IMG file for FlashFloppy?

21
Hardware / Re: Capacitors - wrong orientation?
« on: 2020.October.02. 08:55:25 »
So, by using a bipolar capacitor we can improve the situation?

22
Interface / Re: Internal memory expansion
« on: 2020.September.28. 17:21:58 »
Not to compete with the professionals here, but as a personal learning experience, I also created a pcb of my GAL based SRAM solution. It was a pain to create (I used KiCad) since I have never done anything like this before. Now I am really nervous if this is going to work at all. :roll:

23
Other topics / Re: How can one switch between WP versions?
« on: 2020.September.28. 10:53:07 »
I think that 2.6 was designed to replace 2.1 so you can't actually call it with an EXOS command. 2.6 does everything the original does so there's really no reason to use the original.

However the code is still there in the ROM so you can always call it directly if you want. For example, from BASIC...

Code: [Select]
CALL USR(62907,0)
Thanks, this works.
Not that I would be using it anyway, it is more curiosity than anything else. :)



24
Other topics / How can one switch between WP versions?
« on: 2020.September.27. 19:46:25 »
Beginner question:
EXDOS 2.4 ROM contains two WP versions (2.1 and 2.6). How can I load each version?
:WP seems to load WP2.6

 
 

25
Hardware / Re: RF signal only black&white
« on: 2020.September.24. 16:33:23 »
Success!
This was a hard one. I replaced the LM1889, the LM1886, all electrolytic capacitors, the 78L12, most of the transistors and a couple of ceramic capacitors in the LM1889's oscillator circuitry. In the end, changing the 4.433619MHz oscillator solved the color issue. :) 

26
Hardware / Re: Capacitors - wrong orientation?
« on: 2020.September.18. 11:06:51 »
I'm quivering with anticipation, waiting for his reply! ;)

I did a search on forum, looking for all references to "C9", but it didn't turn up any satisfactory explanation.
Same here. :)
All available (different) schematics show the same direction.

27
Hardware / Re: Capacitors - wrong orientation?
« on: 2020.September.16. 22:26:21 »
I don't think that the schematics are wrong.
In fact the capacitor in this  image

is strange. The - arrows point in the direction of the narrowing, opposite to the usual way. Since the visible right side of C9 seems to be metal, I would assume that this is the GND side.

To sum it up, I think
- the right side should be minus
- the arrow on the capacitor in the image above is wrong
- the capacitor in the image above is mounted correctly (+ left / - right)
- the silk screen on the pcb seems to be wrong

I am not an electronics expert, so please convince me that I am wrong.:)

28
Hardware / Re: RF signal only black&white
« on: 2020.September.16. 22:09:04 »
Just curious but did you replace anything to get RGB/scart or was that going for the start? :)
Scart worked right away.

29
Hardware / Re: Capacitors - wrong orientation?
« on: 2020.September.16. 18:25:11 »
Hmmm. Interesting. When I did my recap Ioriented my new C9 as it was on the board. + to the right. So I have the same layout as Wolfgang.

Here are the old. And here the new.

Not to hijack the thread but maybe this error is causing my noise. If it is an error, that is!
I actually turned the new C9 around, since it seems the correct orientation to me.
No real difference to see (yet), at least no smoke and interesting smells.:razz:

Btw., no reason to apologize, I am in the same boat. I also got an Egyptian EP and I am trying to get it up to speed. So far, I upgraded the ROM to EXOS2.4 and built my memory expansion. Now, I am fighting the missing color of the RF signal.:smt017

30
Hardware / Capacitors - wrong orientation?
« on: 2020.September.16. 11:49:54 »
In both my EP64s C9 is oriented like this(minus to the left): https://www.nightfallcrew.com/gallery/enterprise-128-one-two-eight-boxed/IMG_5573.jpg

According to the schematics, the orientation of C9 should be like this (minus to the right):
https://enterpriseforever.com/hardware/ep-repair-service-)-help-with-egyptian-ep64-no-video-outputnot-strating/?action=dlattach;attach=25401;image

Why are they different?
 

Pages: 1 [2] 3