Welcome, Guest. Please login or register.


Author Topic: TFT Monitor tapasztalat (Read 45960 times)

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #240 on: 2017.October.29. 14:30:10 »
19378-019379-119380-2
Z80 System

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #241 on: 2017.October.29. 14:34:15 »
19385-0
Z80 System

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #242 on: 2017.October.29. 14:35:31 »
19386-019387-119388-219389-319390-419391-5
Z80 System

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #243 on: 2017.October.29. 14:36:11 »
19392-019393-1
Z80 System

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #244 on: 2017.October.29. 14:51:48 »
Quote
Az valami ilyesmi lehet (IVIEW kép):
* cb42x256.pic (0.05 kB - downloaded 2 times.)

Hát ez akkor itt most nem nagyon számít már,
mert tudjuk hogy itt ebben a konfigurációban nekem a 78 -as Pixel clock a legjobb beállítás.

Hacsak nincs valami belső érték, vagy értékek, amit az auto tune beállít de nincs kivezetve a menüre,
akkor nem tud jobbat beállítani annál ...

De mondjuk ezt azért érdemes lehet kipróbálni ...

Simán lehet hogy ez a Benq nem is állítja egyáltalán a Pixel clock -ot, csak a Phase -t.
Beállítja 50 -re a Pixel clock -ot bekapcsoláskor, aztán úgy hagyja ahogy kézzel állítod.
Hiába tekerem el 0 -ra és 100 -ra és csinálok egy auto adjustment -et, nem változtatja meg.

Csak a Phase -t allogatja. Azt meg kézzel is próbálgattam 0-63 között állítani (78 -as Pixel clock mellett),
és nem sok hatást vettem észre ... úgy értem reagál rá a kép, de csak masképp lesz rossz (ahol meg rossz 78 -as PC -nél),
nem tisztul a remegés attól.
Z80 System

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #245 on: 2017.October.29. 15:02:59 »
Quote
Quote
Quote from: Z80System on Today at 13:09
Ez a trükk vajon csak ennél az egy típusnál lehet ?

Hol hangzott ez el ? Van erről írva valahol ?


Itt.


Ja de ez a trükk akkor csak ilyen teljes képes nem megjelenést orvosol,

nem pedig zizegést ...

Z80 System

Offline Dr.OG

  • EP fan
  • *
  • Posts: 174
  • Country: hu
  • dr.
  • OS:
  • Linux Linux
  • Browser:
  • Chrome 56.0.2924.87 Chrome 56.0.2924.87
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #246 on: 2017.October.29. 15:09:11 »
Igen, olvastam, pont emiatt rendeltem egyet (na jó, valójában régóta szemeztem vele, ez csak az utolsó csepp volt a pohárban). Sajnos az enyémen annyi ideig sem stabil a kép, hogy lenyomjam a 4 gombot egyszerre. Ha próbáltam is elkapni a megfelelő pillanatot, eddig sosem sikerült...

Az alapvető különbség, hogy az enyém újabb, 3.5-ös verziójú, lehet, ezt már 'javították' ilyen szempontból.

Sikertelenségem másik oka az EP-m is lehet, ahogy olvasgattam, elég komoly a minőségbeli szórás a gépek között.

MIST-tel többé-kevésbé működik, de a PAL core-okat ott sem nagyon szereti. Tapasztalataim bővebben: http://www.atari-forum.com/viewtopic.php?f=115&t=27019&start=125

Ezt a komponens módszert még megpróbálom, hátha működőképes megoldás lesz, akár a scalerrel, akár magában.
Erről hangzott itt el, hogy az a trükkje, hogy a megfelelő időpillanatban le kell nyomni mind a 4 gombját, és akkor hopp, stabil kép lesz EP-vel. Ezt láthattuk is tegnap a klubban.
A magyarázat az lehet, hogy több helyen is írták már, hogy a hardver része nem olyan rossz a cuccnak, de a szoftver az pocsék. A spanyol retrós srácok pl le is vágják az eredeti vezérlő mikrokontrollert, és egy újat kötnek rá, saját programmal.
Ez a 4 gomb nyomásos trükk úgy akaszthatja ki az eredeti szoftvert, hogy az elfelejti futtatni a kép rontó szoftver részt :-)
(Attachment Link)
(Attachment Link)
(Attachment Link)
(Attachment Link)
ÉN ekelek, TE keregsz, Ő gyeleg,
MI ákolunk, TI vornyáztok, ŐK lendeznek.

Offline endi

  • EP addict
  • *
  • Posts: 6997
  • Country: hu
  • grafikus, játékfejlesztõ, programozás, scifi, tudományok, vallás
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 61.0.3163.100 Chrome 61.0.3163.100
    • View Profile
    • Honlapom
Re: TFT Monitor tapasztalat
« Reply #247 on: 2017.October.29. 15:16:35 »
vicces hogy a tévén egyre pengébb képet akarunk elérni, emulátorban meg minél tévésebbet :)
A diplomás magyar programozó megcsinált egy pacmant egy év alatt, majd lefikázta a világ legjobb játékait. :D

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #248 on: 2017.October.29. 15:18:54 »
Quote
Az valami ilyesmi lehet (IVIEW kép):
* cb42x256.pic (0.05 kB - downloaded 2 times.)

Na mégis ki akartam próbálni ezt, ha már ittvan (csodák mindíg vannak),
de nem nyitja meg az IVIEW ...

masik kepet simán megnyit, de ezt nem ...

Z80 System

Offline IstvanV

  • EP addict
  • *
  • Posts: 4804
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 52.0 Firefox 52.0
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #249 on: 2017.October.29. 15:20:48 »
de nem nyitja meg az IVIEW ...

Lehet, hogy ez a tömörített formátumot nem támogató eredeti változat, a CVIEW (amit például az IVIEW.ROM is tartalmaz) meg tudja nyitni.

Ugyanaz a kép .com formátumban:
* cb42x256.com (0.66 kB - downloaded 75 times.)

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #250 on: 2017.October.29. 15:27:10 »
Egyébként tök olyan, mintha minnél tovább használnám az EP -t, annál kevesebb lenne a maradék zizi ... :)

Tehát mintha a melegedés több órán keresztül zajlana ...

Z80 System

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #251 on: 2017.October.29. 15:43:41 »
Quote
Lehet, hogy ez a tömörített formátumot nem támogató eredeti változat, a CVIEW (amit például az IVIEW.ROM is tartalmaz) meg tudja nyitni.

Ugyanaz a kép .com formátumban:
* cb42x256.com (0.66 kB - downloaded 1 times.)


Ez ment.

Nagy varázslat nem történt, nem javította meg hirtelen a dolgot,
de érdekes a működés.

Maga az auto tune továbbra is csak a phase -t állítja, többi paraméterhez nem nyúl (Pixel clock -hoz sem).

De ha elindítottam a checker -t, akkor ugyan szép volt a kép, de ilyen halvány szurkés feketés hullámok szaladkáltak a képen.
Tehát nem zizegésnek vagy remegésnek tűnik, hanem ilyen szürke hullámoknak az amúgy álló checker képen.

Ha arra tátolom az auto tune -t akkor az beállít egy 24 körüli Phase értéket, és a kép nagy részén eltűnnek a hullámok,
kivéve aban a felső néhány "érzékeny" karaktersorban, ott talán még erősebb és sötétebb is lesz a hullámzás szerű zavar.

Ha ezzel a Phase értékkel kimegyek a BASIC képernyőre akkor a status sor jóval erősebben zizeg mint az ideális beállításnál.
Ha itt rátolom az auto tune -t, akkor a Phase értéket 40 körülire állítja be, így a status sor zizegése abba az eddigi legjobb,
csak néha kicsit megrezdülős állapotban lesz.

De ha visszamegyek a checker képre, akkor megint a teljes képernyőn van az a finom kis raszuperponálódott zavar a képen ... :)


Szal gyakorlatilag nem tudja jól megjeleníteni még mindíg.

A táp őrült sokat javított,
a helyes 78 -as Pixel clock is nagyon sokat számít,
a hozzá tartozó Phase érték már alig -alig számít (de azért még mindíg),

a H+V Sync nagyon sokat ront a szituáción (akár meg sem jelenik a kép némelyik LPT -nél),

de még mindíg nem egy stabil OK a helyzet ... :)


A kérdés hogy most egy még jobb (stabilabb) táp,
a Zozo által emlegetett tekercs állogatása,
vagy egy másik input (nem a Benq) irányába kéne -e elmozdulni ...

Z80 System

Offline balagesz

  • EP user
  • *
  • Posts: 265
  • Country: hu
  • OS:
  • Linux (Fedora)) Linux (Fedora))
  • Browser:
  • Firefox 56.0 Firefox 56.0
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #252 on: 2017.October.29. 15:57:24 »
Egészen pontosan 57 * 16 nagy felbontású pixel egy teljes sor, de ez az EXOS dokumentációban is megtalálható.

Ez az 57-es szám valahonnan ismerős... :-D Az eredményül kapott 912 (Dot Clock / Line) "elég magas", pl. a 640×...-es VGA 800-hoz képest legalábbis. A monitor itt "bőven" több, mint 640 pixelnyi széles sort kell majd, hogy visszaadjon, mondjuk 720 környékét? Ez a szám is ismerős valahonnan... ;)

RGB kimenetnél azonban csak a soron belüli pixelek pontos száma igazán fontos.

Pontosan, itt a PAL, mint videoszabvány "nem játszik", maximum annyiban, hogy hozzá közeliek a sor/képfrekvencia értékek.

Kis korrekció, a Pixel clock értéket valóban 0-100 -ig lehet állítani ebben a monitorban, de a Phase érték csak 0-63 -ig megy.

A Phase felbontása "kevésbé fontos", a 64 variáció bőven elegendő kéne, hogy legyen. (Egy régi monitoromnál csak 32 érték volt beállítható, az is elég volt.)

Végigpróbáltam mind a 101 különböző Pixel clock értéket egyesével, valóban mindenhol a teljes képernyőn teljesen zizis, remegős a kép, csak a 78 -ason lesz elfogadható.
(Legalábbis ezzel az EP -vel ...)

Ez egy "digitális" paraméter lesz, minden EP-nél ugyanennek az értéknek kell jónak lenni.

Hát ezt nem értem, én igenis akarhatnám skálázni a képet különböző féle képpen, pld. egész számmal felszorozni a bemeneti felbontást, vagy aspekt helyesen skálázni,
vagy kitölteni a képet, vagy "overscan", vagy ilyesmik ... ez a vacak Benq meg semmit nem enged ezekből ...

Igen, ezek teljesen jogos igények! Egyetértek! :) A teljesen analóg stílusban húzogatom a képméretet típusú beállításnak normál esetben nincs értelme, de ez persze nem normál eset. :-D

Igen, vélhetően a 78 lesz a legközelebbi az ideálishoz, de ezek után simán elképzelem, hogy ez a 0-100 -ig dolog ez nem is feltétlen elegendően pontos érték ...
Szal lehet hogy 77.5 vagy 78.2 jobb jobb lenne, de olyat ez a Benq nem tud ...

Ez az érték - minden épelméjű számítgatás miatt - egy egész szám kell hogy legyen. (Mennyivel szorozza a sorfrekvenciát ahhoz, hogy kijöjjön a Dot Clock értéke.) Ha a monitorban nem az történik, hogy "egy gombnyomás = szorzó egyel állítása", az csak valami marketinges hülyeség lehet! :-D

Simán lehet hogy ez a Benq nem is állítja egyáltalán a Pixel clock -ot, csak a Phase -t.
Beállítja 50 -re a Pixel clock -ot bekapcsoláskor, aztán úgy hagyja ahogy kézzel állítod.
Hiába tekerem el 0 -ra és 100 -ra és csinálok egy auto adjustment -et, nem változtatja meg.

Ez szerintem akkor fordul elő, amikor nagyjából fogalma sincs, hogy mire állítsa. :) Az alap felbontásoknak (VGA 640×480, 800×600...) van egy jellegzetes sorfrekvencia / HSYNC impulzus hossz / sorok száma "mérhető" paramétere. Ha az Auto Adjust alatt olyan értékeket mér, ami megvan egy belső táblázatában, akkor ahhoz tudja, hogy mi a beállítandó érték. Azt relatíve pontosan be tudja állítani. (Jó esetben csak a Phase-t kell finomhangolni, esetleg a pozíciókat.) De ami "nem ismerős", ott - ezek szerint - nem is akar találgatni. :-D

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #253 on: 2017.October.29. 17:32:41 »
Az még egy érdekes mellék,

hogy akartam egy összehasonlítást csinálni, hogy a kínai scaler mennyivel rosszabb text 80 -at mutat mint a Benq natív bemenete,

és mivel eddig a kínai scaler -t a Benq analóg bemenetén néztem, és a kínai scaler valójában HDMI kimenetű,

ezért oda be volt téve még egy aktív HDMI->analóg VGA konverter.


Gondoltam most a fair osszehasonlítés végett azt kiveszem, és HDMI->DVI kábellel fogom hajtani mostantól a scaler -ről a Benq -t.
A Benq papír szerint DVI-D.


Namost kipróbáltam 3 kábelt, köztük olyat is, ami a PC -men egy HDMI kimenetről táplál egy másik DVI TFT monitort,
és a Benq az összes kábel esetén azt mondja hogy nincs input signal ... :)


Vagyis van egy kínai scaler, HDMI kimenettel,

az simán megy HDMI inputokon,
ha a HDMI -t VGA -ra (D-SUB) konvertalom az is megy a Benq monitoron,
de ha a HDMI -t DVI -re konvertálom 3 különböző kábellel, az neki nem jel ... :)

És mindenhol azt mondják hogy a Benq -n nem dísznek van a DVI csatlakozó, hanem DVI-D .

Na erre varrjatok gombot.
Z80 System

Offline Z80System

  • EP addict
  • *
  • Posts: 3837
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 62.0.3202.75 Chrome 62.0.3202.75
    • View Profile
Re: TFT Monitor tapasztalat
« Reply #254 on: 2017.October.29. 18:07:31 »
A jó öreg CRT meg leszarja a tápot, leszarja hogy az EP -nek pontatlan az RGB jele,

símán csak mutatja a képet.

Jó hullámosan, de nem zizizik. (Egy digitális fokozathoz képest.)

Z80 System