Welcome, Guest. Please login or register.


Author Topic: EP64 after few starts no screen over modulator (Read 5478 times)

Online gflorez

  • EP addict
  • *
  • Posts: 3124
  • Country: es
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 83.0 Firefox 83.0
    • View Profile
Re: EP64 after few starts no screen over modulator
« Reply #15 on: 2020.November.26. 15:36:20 »
Ah, curious... Sellmyretro still sells the Enterprise membrane? good news. It also has good quality, I have used both, the English and the Hungarian. The first more expensive, but the second farer from you(and me), so you pay more shipping.

The EDGE connector used is the 2,54mm pitch type, like on Spectrum and Amstrad.

Yes, Retrocables makes the cables one by one on demand. Order them the cables on their web page, never on Ebay....

Offline Judge

  • EP user
  • *
  • Posts: 437
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 87.0.4280.66 Chrome 87.0.4280.66
    • View Profile
Re: EP64 after few starts no screen over modulator
« Reply #16 on: 2020.November.26. 17:03:28 »
25849-0

25851-1

25853-2
Üdv.Judge

Online gflorez

  • EP addict
  • *
  • Posts: 3124
  • Country: es
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 83.0 Firefox 83.0
    • View Profile
Re: EP64 after few starts no screen over modulator
« Reply #17 on: 2020.November.26. 18:03:18 »
Yes, and Judge from Hungary makes a much better cable. I didn't mentioned it because you have already ordered yours.

Offline rambrand

  • Newbie
  • Posts: 7
  • Country: de
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Firefox 83.0 Firefox 83.0
    • View Profile
    • Lord Luxor Retro Galerie
Re: EP64 after few starts no screen over modulator
« Reply #18 on: 2020.December.11. 22:15:00 »
Meanwhile the cable arrives.

I´ve tested the EP 64 over the monitor connector and still get no signal on the monitor. Used the same cable with an EP 128 and getting a signal there.

So the EP 64 has an issue booting up.

May I´ll send him to a repair service. I don't know enough about the device to repair it. I´m looking here for some repair services. Can anyone recommend a good repair service?

Bye
Markus
"Nukular. Das Wort heißt Nu-ku-lar." - Homer Simpson
--------
Amiga 500,Atari 1040STFM,C16,C64 II + C1541 II + C1530,Enterprise 64,ZX 81,ZX Spectrum 48k/+,ZX Spectrum 128k+/+2/+2B/+3,QL,Spectral,Harlequin 128k,Timex 2048 Link

Offline Dr.OG

  • EP user
  • *
  • Posts: 367
  • Country: hu
  • dr.
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 87.0.4280.88 Chrome 87.0.4280.88
    • View Profile
ÉN ekelek, TE keregsz, Ő gyeleg,
MI ákolunk, TI vornyáztok, ŐK lendeznek.