Welcome, Guest. Please login or register.


Author Topic: HxC manager - garbled boot screen - do I have the right HXCSDFE.CFG (Read 522 times)

Offline John Fante

  • User
  • *
  • Posts: 67
  • Country: dk
  • OS:
  • Mac OS X 10.13.6 Mac OS X 10.13.6
  • Browser:
  • Chrome 68.0.3440.84 Chrome 68.0.3440.84
    • View Profile
Until I find what wrong with your images...
Can you try my image?

I have tried your SD card and it works. HxC can mount disks fine and they are mounted in basic when I pres F1 :lol: Same SD card etc.

I then copied the image I sent you yesterday back to the SD card and replaced my HXCSDFE.CFG with the one from your card and now everything works. Apparently there is something different between the two. But what it is ....

Offline Zozosoft

  • EP addict
  • *
  • Posts: 12953
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Firefox 61.0 Firefox 61.0
    • View Profile
    • http://enterprise.iko.hu/
Great news! :ds_icon_cheesygrin:

Offline Zozosoft

  • EP addict
  • *
  • Posts: 12953
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Firefox 61.0 Firefox 61.0
    • View Profile
    • http://enterprise.iko.hu/
Solved! :ds_icon_cheesygrin:

At the HxC Floppy emulator settings remove the "enable auto boot mode" setting.
If it is enable then it is switch to Slot mode, and don't use the selected filenames which saved to the CFG file. And it is forgot the last mounted file when exit from direct mode or power off/on, or remove/insert SD Card.

This setting stored at 0x0016 byte in the CFG file, 00 normal mode, 01 slot mode.

Offline John Fante

  • User
  • *
  • Posts: 67
  • Country: dk
  • OS:
  • Mac OS X 10.13.6 Mac OS X 10.13.6
  • Browser:
  • Chrome 67.0.3396.99 Chrome 67.0.3396.99
    • View Profile
Solved! :ds_icon_cheesygrin:

At the HxC Floppy emulator settings remove the "enable auto boot mode" setting.
If it is enable then it is switch to Slot mode, and don't use the selected filenames which saved to the CFG file. And it is forgot the last mounted file when exit from direct mode or power off/on, or remove/insert SD Card.

This setting stored at 0x0016 byte in the CFG file, 00 normal mode, 01 slot mode.

Cool :ds_icon_cheesygrin: Way to go!!

A bit strange/surprising, thou: If you look at the Emulator Manager programs for Amstrad, Amiga, ST then they all have "Enable auto boot mode" checked.

But thank you none the less for solving it :smt041
« Last Edit: 2018.August.08. 17:31:35 by John Fante »