Welcome, Guest. Please login or register.


Author Topic: 2 questions: No RGB signal (HELP) and can I upgrade EP64 to EXOS 2.4 etc. (Read 1083 times)

Online John Fante

  • EP fan
  • *
  • Posts: 136
  • Country: dk
  • OS:
  • Mac OS X 10.15.6 Mac OS X 10.15.6
  • Browser:
  • Chrome 84.0.4147.125 Chrome 84.0.4147.125
    • View Profile
And about leaving your "old EP" without the internal ROM, you say that you plan to inject it with the SF3.

Ok, remember to put on the INI file the line

Code: [Select]
ROMEXOS_ENA=ON
and the line

Code: [Select]
ROM[#00]  =SD:EXOS2.4.ROM
Remember that your old EP will only start with the SF3 connected.

Thank you :)

So an INI file like this should do the trick for an EP64 with the old rom removed?

Code: [Select]
************************************************************************************
*      SF3 INI FILE                                        
************************************************************************************
*Wifi settings.  Up to 5 wifi providers can be put here,  
*                the first has the gratest priority

@WIFI_PASS=XXX
@WIFI_SSID=YYYY
 
WIFI_CONNECT
************************************************************************************

*TMTnet settings

TMTNET_USERID=???
TMTNET_PASS=ZZZ

************************************************************************************

*EPRAM[#05-#07]
EPRAM[#08-#1F]
EPRAM[#30-#F7]

* The Roms can be in any place of the SD or on a web page

ROMEXOS_ENA=ON
ROM[#00]  =SD:ROMS/exos24uk.ROM
ROM[#60]  =SD:ROMS/SF3BOOT.ROM
*ROM[#61]  =SD:ROMS/SPEMU128.ROM
*ROM[#64]  =SD:ROMS/epd19uk.rom
*ROM[#66]  =SD:forth.rom

*ROM[#67] =HTTP:www.tmtlogic.com/cyrus.rom

************************************************************************************
* Audio settings SYMAMP for symbos audio
 
*AUDIO=  PLAYMS
AUDIO=  SYMAMP
************************************************************************************

Offline Judge

  • EP user
  • *
  • Posts: 351
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 84.0.4147.135 Chrome 84.0.4147.135
    • View Profile
Thank you for all the great advise :)

Just one thing. On my present machine the ROM is not wired to the expansion port but to the U6 chip. See here.

The wire to the expansion port is wired like this.

Is this an alternative way of doing it?

Yes, there also the A15 (U6 17. pin)

25287-0
« Last Edit: 2020.August.20. 16:01:01 by Judge »
Üdv.Judge

Online gflorez

  • EP addict
  • *
  • Posts: 2934
  • Country: es
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 68.0 Firefox 68.0
    • View Profile
Yes, that's it, with the SF3 you can inject a Rom on  segments 00-03 on any Enterprise (of course, without the internal Rom installed).

These EPs from Egypt seem all to be new. Please take a lot of care while opening it!

Online gflorez

  • EP addict
  • *
  • Posts: 2934
  • Country: es
  • OS:
  • Windows NT 6.3 Windows NT 6.3
  • Browser:
  • Firefox 79.0 Firefox 79.0
    • View Profile
You have the same easy point on all Enterprises. This is a close-up of your picture:



Ok, now I realise,  I have not seen Judge's better explanation.
« Last Edit: 2020.August.20. 19:25:40 by gflorez »

Offline Judge

  • EP user
  • *
  • Posts: 351
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 84.0.4147.135 Chrome 84.0.4147.135
    • View Profile
Explanation: gflorez says it's the easy point on every Enterprise because the top memory panel on the 128K machine  covers the U6 chip...

25291-0
Üdv.Judge