Welcome, Guest. Please login or register.


Author Topic: Videó chipet keres Nick (Read 2185 times)

Offline Zeroperf

  • Newbie
  • Posts: 9
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 87.0.4280.88 Chrome 87.0.4280.88
    • View Profile
Videó chipet keres Nick
« on: 2021.January.14. 15:32:22 »
Hello kedves!
A megkeresés válaszol, akinek lehetősége van segíteni!
Az Enterprise 128-as verziómban a video chip meghibásodott: AMI 8516DBT NICK 01 ENTER 08-47.
Megkaphatnám ezt a chipet elfogadható áron, ha van alaplapod elemzés alatt?
Várom válaszait!
Köszönöm, jókívánságokkal, Vitalij.

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13892
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 84.0 Firefox 84.0
    • View Profile
    • http://enterprise.iko.hu/
Re: Videó chipet keres Nick
« Reply #1 on: 2021.January.15. 09:25:45 »
1) Are you sure about the Nick is the faulty? A lot of other component failure can result broken or empty black screen.

Biztos vagy benne, hogy a Nick hibásodott meg? Sok más alkatrész hibája okozhat hibás vagy üres, fekete képernyőt.

2) If the Nick is really dead then the only hope is to find a faulty machine where the Dave is dead and the Nick is good...
Few weeks ago there was one in this topic.

Ha tényleg a Nick hibásodott meg, akkor az egyetlen remény találni olyan hibás gépet, amiben a Dave halott és a Nick jó.
Pár hete volt egy ilyenről szó itt.
« Last Edit: 2021.January.15. 11:22:16 by szipucsu »

Offline Zeroperf

  • Newbie
  • Posts: 9
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 87.0.4280.88 Chrome 87.0.4280.88
    • View Profile
Re: Videó chipet keres Nick
« Reply #2 on: 2021.January.15. 11:07:51 »
Köszönöm, legalább valaki válaszolt.
A helyzet a következő. Megpróbáltak 40 MHz-es kvarcot betenni az autóba, egyértelmű, hogy az nem ment tovább az indulásnál. És éjszakára hagyta. Reggel fekete képernyő. Nick hűtőbordája szinte teljesen elakadt. Bekapcsoláskor zajok hallhatók, gyakrabban csak fekete képernyő. Megpróbálja megváltoztatni a memóriát, a puffereket?

Offline szipucsu

  • EP addict
  • *
  • Posts: 8870
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 84.0 Firefox 84.0
    • View Profile
    • Webnyelv.hu - Tanuljunk nyelveket!
Re: Videó chipet keres Nick
« Reply #3 on: 2021.January.15. 11:25:21 »
What is your language? You can write in English or in your language without Hungarian Google translate. We will understand.
100 SOUND SOURCE 3,STYLE 16,LEFT 16,RIGHT 64,SYNC 2
110 SOUND SOURCE 2,STYLE 128,PITCH 25.2,SYNC 2
120 SOUND PITCH 25,SYNC 2
Videos

Offline Zeroperf

  • Newbie
  • Posts: 9
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 87.0.4280.88 Chrome 87.0.4280.88
    • View Profile
Re: Videó chipet keres Nick
« Reply #4 on: 2021.January.15. 11:26:04 »

Érdekes módon a tulajdonos azt mondja, hogy az eredetileg Kazahsztánban, Rudny városában vásárolt számítógép kezéből az orosz "Avito" értékesítési rendszeren keresztül, amelyet egyáltalán nem hirdettek, rendkívül furcsán viselkedett. Az indítás után semmit sem lehetett betölteni. A legtöbb kulcs nem működött. Kiderült, hogy a kábel megrepedt, levágódott és kicserélték a billentyűzet csatlakozóit. De legalább egy programot nem tudtam betölteni. Aztán elkezdtek kísérletezni ...
 Nos, és akkor megtörtént az, amit fentebb olvastál.

Offline Zeroperf

  • Newbie
  • Posts: 9
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 87.0.4280.88 Chrome 87.0.4280.88
    • View Profile
Re: Videó chipet keres Nick
« Reply #5 on: 2021.January.15. 11:27:51 »
Orosz nyelv.

Offline Zeroperf

  • Newbie
  • Posts: 9
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 87.0.4280.88 Chrome 87.0.4280.88
    • View Profile
Re: Videó chipet keres Nick
« Reply #6 on: 2021.January.15. 11:30:15 »
Russian language.
Interestingly, the owner says that the computer, originally purchased in Rudny, Kazakhstan, through the Russian Avito sales system, acted extremely strange. After launching, nothing was loaded. Most of the keyboard buttons did not work. The cable was found to be cracked, cut off, and the keyboard connectors replaced. But we couldn't load at least one program. Then they started experimenting ...
 Well, then what you read above happened.

Offline Zeroperf

  • Newbie
  • Posts: 9
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 87.0.4280.88 Chrome 87.0.4280.88
    • View Profile
Re: Videó chipet keres Nick
« Reply #7 on: 2021.January.15. 11:32:25 »

Thank you, at least someone answered.
The situation is as follows. They tried to put quartz at 40 MHz in the car, it is clear that it did not go further than the start. And he left him for the night. Black screen in the morning. Nick's radiator fell off almost completely. When turned on, noise is visible on the screen, but rarely, more often only a black screen. Do you offer to change memory, buffers?

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13892
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Firefox 84.0 Firefox 84.0
    • View Profile
    • http://enterprise.iko.hu/
Re: Videó chipet keres Nick
« Reply #8 on: 2021.January.15. 11:37:05 »
The 8MHz replaced to 40MHz? :shock: Now replaced back?

Then my primary suspect are Dave.

Do you have a oscilloscope or least TTL probe? And EPROM programmer?
« Last Edit: 2021.January.15. 11:40:37 by Zozosoft »

Offline Zeroperf

  • Newbie
  • Posts: 9
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 87.0.4280.88 Chrome 87.0.4280.88
    • View Profile
Re: Videó chipet keres Nick
« Reply #9 on: 2021.January.15. 11:40:09 »

Yes, they replaced it with 8 MHz, which was. No, there is no oscilloscope, alas ((

Offline Zeroperf

  • Newbie
  • Posts: 9
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Chrome 87.0.4280.88 Chrome 87.0.4280.88
    • View Profile
Re: Videó chipet keres Nick
« Reply #10 on: 2021.January.15. 11:42:28 »

There is a programmer

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13892
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Firefox 84.0 Firefox 84.0
    • View Profile
    • http://enterprise.iko.hu/
Re: Videó chipet keres Nick
« Reply #11 on: 2021.January.15. 12:26:36 »
Most of the keyboard buttons did not work. The cable was found to be cracked, cut off, and the keyboard connectors replaced.
It is not a surprise, the 35+ years membranes are very often crack.

Nick's radiator fell off almost completely.
It is also common problem, the old glue is aged.
But the Nick chip can run without it! The heat shink are only as "first aid" for the first generation Nick chips (08-04) display problems.
08-47 can work without it.

The most dangerous about it: if completely fell off, and moving in machine inside, possible to make short circuit on some pins.

Quote
When turned on, noise is visible on the screen, but rarely, more often only a black screen. Do you offer to change memory, buffers?
First important thing: the Nick are completly software controlled. On other machines, for example on ZX Spectrum you can get stable screen with border and screen area even if system don't start.
The un-initialised Nick chip only display some little screen garbage, depending how the video memory chips are random filled on powerup. These gargabe are generaly random, but usually always same on each machines. Probably depend of memory chip type.
Most usual types:
- wide black-white columns
- black screen with a little running lines (which are border color, it is random initialised at power on)
- black screen with running dark red garbage

Second important thing: EXOS ROM have a bug: place the stack pointer to unverified memory when call testing routine for a System Segment. If the onboard memory faulty then when returning from CALL, get a broken return address from the stack, then system crash without report the memory problem. (Because jump to random address then possible make some sound at crash)
And at the beginning the EXOS set the border color to black, then very often you got a empty black screen when this happen.

First try: remove the ROM chip, then the Nick remain fully uninitialised (border not set black). Need often see the mentoined screen garbage.

There is a programmer
Nice!
Then try my beeping diag ROMs:
It is don't use any memory, don't use stack.
Start testing the onboard memory, writing 00h, FFh, 55h, AAh to each byte. After write read back and make a sound of each bits, low and high tone beeps bor a 0 and 1. Then you can detect if some RAM chips are dead.
When beeping the border color are also flashing.
TESZTOLD: don't touch the Nick chip, remain with the power on state
TESZT: define a character screen (but if the onboard memory very faulty this can't displayed)

If this test can started, you can get some life sign from the machine. If not started then more serious problem :-(

One note: connect speakers to the tape output, for avoid if there is a problem with the internal speaker.