Welcome, Guest. Please login or register.


Author Topic: EP128emu (Read 112285 times)

Offline IstvanV

  • EP addict
  • *
  • Posts: 4377
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 52.0 Firefox 52.0
    • View Profile
Re: EP128emu
« Reply #1200 on: 2017.November.05. 14:13:43 »
RANDOMIZE után készült snapshottal a BASIC véletlenszám generátora (ami egy egyszerű 23 bites LFSR) teljesen kiszámítható. Ha a snapshot töltése és a RANDOMIZE utasítás közötti idő nem konstans (pl. billentyűre várakozás miatt), akkor lesz mindig más sorozat.

Offline Tomato77

  • User
  • *
  • Posts: 96
  • Country: hu
  • OS:
  • Linux Linux
  • Browser:
  • Chrome 50.0.2661.94 Chrome 50.0.2661.94
    • View Profile
Re: EP128emu
« Reply #1201 on: 2017.November.13. 16:34:26 »
Sziasztok!
Megpróbáltam feltelepíteni az EP128emu-t egy régi PC-re, de az alábbi hibát írja ki és nem indul. A 2.0.11.1-x86 verzióval próbálkoztam. A gép egy P3-as laptop Win XP-vel, 384 mega RAM-mal. Ha jól láttam, XP alatt kéne mennie. Kell még valami az emulátornak? Vagy kicsi neki a gép és próbálkozzak régebbi verzióval?
Kotasoft     Kotasoft

Offline IstvanV

  • EP addict
  • *
  • Posts: 4377
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 52.0 Firefox 52.0
    • View Profile
Re: EP128emu
« Reply #1202 on: 2017.November.13. 17:01:05 »
A 2.0.11.1 elvileg még működik, a 2.0.11.2-vel már problémák vannak, valószínűleg a PortMidi miatt. De egyes gépeken előfordult már hasonló hiba, talán driver függő lehet, vagy valamelyik DLL P3-nál újabb CPU-t igényel (nem mindet én fordítottam). Driver probléma esetén talán működik a szoftveres video mód, vagy a hang letiltása. Természetesen ha már indításkor lefagy, akkor az utóbbi csak konfigurációs file vagy parancssor szerkesztésével lehetséges.

Offline Attus

  • EP addict
  • *
  • Posts: 1224
  • Country: hu
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 58.0 Firefox 58.0
    • View Profile
Re: EP128emu
« Reply #1203 on: 2018.January.29. 21:57:58 »
István!

 https://github.com/istvan-v/ep128emu/issues/4

Szerintemez téves.
Biztosan ubuntu specifikus gondja van, nem pedig a kódodban van a hiba.

Nem tudom, hogy szegénynek mi gondja lehet az fltk3 -al, nekem semmi gondom vele.
Szépen elkészül az ep128emu fltk-1.3.3 és fltk-1.3.4 -el is. Előbbi az UHU-UBK1 -en kész, utóbbi a nemsokára megjelentethető UBK2 -n 32 és 64 biten is elkészült.
UBUNTU jobban aprózza az fltk -t, mint mi. Nekünk nincs külön lehasított libfltk3 csomagunk. Tudom, hogy debian, fedora, meg ubuntu szanaszét aprózzák a kiinduló forrásból létrejött cuccot sok apró, különböző nevű csomagocskára.
Talán LGB, mint nagy UBUNTU használó tudna neki segíteni.