Welcome, Guest. Please login or register.


Author Topic: ep128emu 2.0.9 (Read 75026 times)

Offline IstvanV

  • EP addict
  • *
  • Posts: 4825
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 39.0 Firefox 39.0
    • View Profile
Re: ep128emu 2.0.9
« Reply #225 on: 2015.December.21. 10:15:28 »
14397-0

14399-1

Offline endi

  • EP addict
  • *
  • Posts: 7305
  • Country: hu
  • grafikus, játékfejlesztõ, programozás, scifi, tudományok, vallás
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 47.0.2526.73 Chrome 47.0.2526.73
    • View Profile
    • Honlapom
Re: ep128emu 2.0.9
« Reply #226 on: 2015.December.21. 10:21:19 »
jaja ez így jól használható, köszi
Vigyázat! Szektás vagyok! :)

Offline ssr86

  • EP user
  • *
  • Posts: 359
  • Country: pl
  • OS:
  • Windows NT 6.2 Windows NT 6.2
  • Browser:
  • Firefox 42.0 Firefox 42.0
    • View Profile
Re: ep128emu 2.0.9
« Reply #227 on: 2015.December.23. 17:55:59 »
Don't know if it's the right place to post about it but it seems that the timings of the emulator are not accurate (in favor of the real thing). I'm currently testing a wip of the hattrick on the real machine and the border color changes indicate that on the real machine the tested code is executed quicker by about ~32 scanlines or so - huge difference. The code is mainly sprite code so a lot of vmem access.

The screenshot shows how it looks on the emulator. I can't post aphoto of the thing running on the computer but the execution ends about 5 lines after the start of the blue on the screenshot (also I see right away that the blue area takes less - it's the drawing of goalkeepers)
« Last Edit: 2015.December.23. 18:01:13 by ssr86 »

Offline IstvanV

  • EP addict
  • *
  • Posts: 4825
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 39.0 Firefox 39.0
    • View Profile
Re: ep128emu 2.0.9
« Reply #228 on: 2015.December.23. 18:24:35 »
Can you post this program for testing, or at least a part of it that is enough to reproduce the timing issue ?

Offline ssr86

  • EP user
  • *
  • Posts: 359
  • Country: pl
  • OS:
  • Windows NT 6.2 Windows NT 6.2
  • Browser:
  • Firefox 42.0 Firefox 42.0
    • View Profile
Re: ep128emu 2.0.9
« Reply #229 on: 2015.December.23. 18:45:12 »
Can you post this program for testing, or at least a part of it that is enough to reproduce the timing issue ?
Do you want the executables only or the source code too?

Offline IstvanV

  • EP addict
  • *
  • Posts: 4825
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 39.0 Firefox 39.0
    • View Profile
Re: ep128emu 2.0.9
« Reply #230 on: 2015.December.23. 18:58:30 »
The source code is not important, it is enough if I can run the problematic sprite drawing routine, and also others could try it on real machines.

Offline szipucsu

  • EP addict
  • *
  • Posts: 8584
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 43.0 Firefox 43.0
    • View Profile
    • Webnyelv.hu - Tanuljunk nyelveket!
Re: ep128emu 2.0.9
« Reply #231 on: 2015.December.23. 20:58:38 »
Nem lenne érdemes az angol nyelvű kommenteket különválasztani, és egy külön, angol nyelvű emulátoros topikba tenni?
100 SOUND SOURCE 3,STYLE 16,LEFT 16,RIGHT 64,SYNC 2
110 SOUND SOURCE 2,STYLE 128,PITCH 25.2,SYNC 2
120 SOUND PITCH 25,SYNC 2
Videos

Offline ssr86

  • EP user
  • *
  • Posts: 359
  • Country: pl
  • OS:
  • Windows NT 6.2 Windows NT 6.2
  • Browser:
  • Firefox 42.0 Firefox 42.0
    • View Profile
Re: ep128emu 2.0.9
« Reply #232 on: 2015.December.23. 20:59:33 »
Ok, I've attached the executable

Offline IstvanV

  • EP addict
  • *
  • Posts: 4825
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 39.0 Firefox 39.0
    • View Profile
Re: ep128emu 2.0.9
« Reply #233 on: 2015.December.24. 10:05:42 »
Thanks. Is it possible that on your machine wait states are disabled on the BFh port of DAVE ? Some versions of one of the ROMs (I do not remember exactly which one, it has been fixed in the emulator ROM package a while ago) do this by default. Here is what it looks like on the emulator after writing 0Ch to the port:
14442-0

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13718
  • Country: hu
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Firefox 43.0 Firefox 43.0
    • View Profile
    • http://enterprise.iko.hu/
Re: ep128emu 2.0.9
« Reply #234 on: 2015.December.24. 11:09:13 »
Yes, latest version of my Quick Memory Test are disable the wait states. This test included in SD Card interface ROM package, and in latest EXOS ROM.

The BFh port setting also recommended to the program, running properly on all config.

Offline ssr86

  • EP user
  • *
  • Posts: 359
  • Country: pl
  • OS:
  • Windows NT 6.2 Windows NT 6.2
  • Browser:
  • Firefox 43.0 Firefox 43.0
    • View Profile
Re: ep128emu 2.0.9
« Reply #235 on: 2015.December.24. 12:27:23 »
Thanks. Is it possible that on your machine wait states are disabled on the BFh port of DAVE ? Some versions of one of the ROMs (I do not remember exactly which one, it has been fixed in the emulator ROM package a while ago) do this by default. Here is what it looks like on the emulator after writing 0Ch to the port:
(Attachment Link)

Well... looks like it was the issue :oops:
Sorry for your time.
 

Offline minmax

  • Beginner
  • *
  • Posts: 41
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Opera 9.80 Opera 9.80
    • View Profile
Re: ep128emu 2.0.9
« Reply #236 on: 2016.February.13. 00:53:45 »
Sziasztok!

Az lenne a kérdésem, hogy hogyan lehetne hangot varázsolni az emura, mert sajnos bármit állítgatok, bármilyen eszközt választok ki, eddig még meg sem mukkant. Rákerestem, de nem találtam olyat, hogy valakinél ez előfordult volna.
WinXP SP3, 2,66 MHz Celeron egy noname hangkártyával, semmi extra. Hangerőszabályzóba is benéztem. :)



Na, arra már rájöttem, hogy a Machine Speed-el, illetve a CPU Frequency-vel van összefüggésben a probléma. Akkor ad ki legnormálisabb hangot, amikor 100%-ra van állítva, bár ekkor is olyan remegős, akadozik, mintha túl lenne terhelve a gép. Viszont ahogy állítgatom PageUp/Down-al vagy a menüben a speed-et, akkor vagy nagyon kis gyenge krákogás lesz belőle vagy teljesen megnémul, de inkább az utóbbi.
« Last Edit: 2016.February.13. 01:39:45 by minmax »

Offline IstvanV

  • EP addict
  • *
  • Posts: 4825
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 39.0 Firefox 39.0
    • View Profile
Re: ep128emu 2.0.9
« Reply #237 on: 2016.February.13. 09:52:57 »
Ha nem 100% a sebesség (Machine/Speed), akkor nincs hang, ez nem hiba. Ha akadozik a hang, akkor lehet, hogy nem elég gyors a gép a 100% sebességhez (ez nem valószínű Pentium III vagy jobb processzorral - remélhetőleg az a Celeron valójában 2.66 GHz-es :)), illetve gyakrabban driver probléma okozhatja. Az OpenGL helyett érdemes megpróbálni a szoftveres video módot, mert az előbbivel előfordulhat jelentős lassulás bizonyos kártyákkal/driverekkel (pl. régi laptopon). A hang beállításoknál a legjobban az "MME" kimenetek működnek, ezen kívül még lehet próbálkozni a "Latency" növelésével, bár elvileg az alapértelmezett beállításoknak működni kellene XP-n.

Offline minmax

  • Beginner
  • *
  • Posts: 41
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Opera 9.80 Opera 9.80
    • View Profile
Re: ep128emu 2.0.9
« Reply #238 on: 2016.February.14. 01:21:12 »
Jaj, köszi, a szoftveres mód megoldotta a problémát.
Gondoltam is, hogy kipróbálom, de a readme azt írja, hogy:
"  -no-opengl
    use software video driver; this is slower than OpenGL when used at high resolutions..."
Tehát, hogy pont szoftveresen lassabb (nagy felbontásokon). Ezért nem is próbálkoztam, mert így is eléggé fogta a gépet az emu. (2.66 GHz, persze.) OpenGL-el alapból is olyan 50-100% között ment a proci, hogyha felvittem 40.000.000-ra a frekit, akkor ment jobban, 50-70% között. Szoftveresen alapból meg néhány %, ha megdolgoztatom akkor 20%. Szóval ezzel nagyjából minden problémám megoldódott, remélem. :)
Amúgy nálam a directsound-al kevésbé akadozott a hang egy kicsivel, mint mme-vel. Viszont ha felvettem a hangot, akkor az mindig tökéletes volt, csak a hangszóróban volt rossz.
Igen, közben azt is megsejtettem, hogy csak 100%-on van hang, hát ez van.

A billentyűpittyegést nem lehet alapból kikapcsolttá tenni valahogy? Nem mintha olyan fárasztó lenne megnyomni az F7-et, csak...

Offline endi

  • EP addict
  • *
  • Posts: 7305
  • Country: hu
  • grafikus, játékfejlesztõ, programozás, scifi, tudományok, vallás
  • OS:
  • Windows 7/Server 2008 R2 Windows 7/Server 2008 R2
  • Browser:
  • Chrome 48.0.2564.82 Chrome 48.0.2564.82
    • View Profile
    • Honlapom
Re: ep128emu 2.0.9
« Reply #239 on: 2016.February.14. 10:20:22 »
nagyobb sebességet úgy is el tudsz érni hogy a z80 clock-ot magasabbra állítod, ez esetben a hang (legalábbis az exos hang) jó marad
Vigyázat! Szektás vagyok! :)