ENTERPRISE KLUB
2019. szeptember 7., 1055 Budapest, Nyugati tér 9. 14-19 óráig
Részletek
Welcome, Guest. Please login or register.


Author Topic: ep128emu 2.0.7 (Read 68278 times)

Offline IstvanV

  • EP addict
  • *
  • Posts: 4806
  • OS:
  • Linux (Suse) Linux (Suse)
  • Browser:
  • Konqueror 3.5.9 Konqueror 3.5.9
    • View Profile
ep128emu 2.0.7
« on: 2009.August.02. 18:31:11 »
Megjelent az ep128emu 2.0.7. Az új verzió ezeket a változtatásokat tartalmazza a 2.0.6-hoz képest, és innen lehet letölteni.

Offline Ep128

  • EP addict
  • *
  • Posts: 1645
  • Country: hu
  • OS:
  • Windows Vista Windows Vista
  • Browser:
  • Firefox 3.0.6 Firefox 3.0.6
    • View Profile
    • Honlapom
Re: ep128emu 2.0.7
« Reply #1 on: 2009.August.02. 18:43:33 »
Köszönjük!  :)

Offline IstvanV

  • EP addict
  • *
  • Posts: 4806
  • OS:
  • Linux (Suse) Linux (Suse)
  • Browser:
  • Firefox 3.0.11 Firefox 3.0.11
    • View Profile
Re: ep128emu 2.0.7
« Reply #2 on: 2009.August.03. 13:12:47 »
A wiki-t frissítettem (ha esetleg még olvassa vagy szerkeszti valaki :razz:; változások).

Egyébként a wiki-t és/vagy az ep128.hu emulátor oldalát ki lehetne egészíteni az IDE emuláció leírásával is.
« Last Edit: 2009.August.03. 13:23:06 by IstvanV »

Online szipucsu

  • EP addict
  • *
  • Posts: 7876
  • Country: hu
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.5.1 Firefox 3.5.1
    • View Profile
    • Webnyelv.hu - Tanuljunk nyelveket!
Re: ep128emu 2.0.7
« Reply #3 on: 2009.August.03. 21:39:51 »
A wiki-t frissítettem (ha esetleg még olvassa vagy szerkeszti valaki :razz:; változások).

Köszi!
Én szoktam amúgy használni.

Egyébként a wiki-t és/vagy az ep128.hu emulátor oldalát ki lehetne egészíteni az IDE emuláció leírásával is.

Ez a dolog nekem kicsit kínai, jobb lenne, ha valaki megcsinálná. Javaslom amúgy a wikin pl. egy "Az IDE.ROM használata" vagy valami hasonló cím alá betenni. Bár lehet, ez nem kapcsolódik olyan szorosan az emulátorhoz, talán külön oldal is lehetne neki, ahogy pl. az Iview-nek, Iplay-nek is van. Vagy nem tudom, annyira azért nem értek hozzá.  :oops: :D
SOUND SOURCE 3,STYLE 16,LEFT 16,RIGHT 64,SYNC 2
SOUND SOURCE 2,STYLE 128,PITCH 25.2,SYNC 2
SOUND PITCH 25,SYNC 2
Videos

Offline IstvanV

  • EP addict
  • *
  • Posts: 4806
  • OS:
  • Linux (Suse) Linux (Suse)
  • Browser:
  • Firefox 3.0.11 Firefox 3.0.11
    • View Profile
Re: ep128emu 2.0.7
« Reply #4 on: 2009.August.06. 11:35:59 »
Csak az ajánlásod alapján tiltottam most le, de nem láttam semmi hatását a tiltásnak-engedélyezésnek. Megfelõ ezek szerint az UHU SDL verziója, ezért a továbbiakban engedélyezem.
 :)

:idea:
A reprodukálhatóság miatt jó lenne valahol a neten belõle egy stabil, nem folyton változó tar.bz2, vagy tar.gz, hogy ne ilyen agyafúrt módon kelljen letölteni.

Mindenesetre leszedem, teszt célra.. :)

Időközben már megjelent a 2.0.7, csak a nem túl nagy érdeklődés miatt ez a topic elveszett a sok más témájú hozzászólás között :) Tehát a SourceForge-ról letölthető a forrás .tar.bz2, és természetesen a 32 és 64 bites binárisok is a fenti címen. De a cvs export -r ep128emu-2_0_7 sem változik, és később is ugyanazt a forráskódot fogja letölteni, mint ami a .tar.bz2-ben van.

Offline Attus

  • EP addict
  • *
  • Posts: 1230
  • Country: hu
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 2.0.0.16 Firefox 2.0.0.16
    • View Profile
Re: ep128emu 2.0.7
« Reply #5 on: 2009.August.08. 09:25:52 »
Idõközben már megjelent a 2.0.7, csak a nem túl nagy érdeklõdés miatt ez a topic elveszett a sok más témájú hozzászólás között :) Tehát a SourceForge-ról letölthetõ a forrás .tar.bz2, és természetesen a 32 és 64 bites binárisok is a fenti címen. De a cvs export -r ep128emu-2_0_7 sem változik, és késõbb is ugyanazt a forráskódot fogja letölteni, mint ami a .tar.bz2-ben van.

Ez jó hír.  :)

Néztem a Sconstruct -ot, igen sokat dolgoztál rajta. :bow:
Az eredmény: UHU 2.1 alá hibátlanul lefordítható, nem kell beerõltetnem a lua újabb verzióját sem, sem semmi sed szkripttel meggyúrnom.   :smt041

Gond már csak az UHU 2.0 van, de nem tudom, hogy ez lényegbevágó -e?
Az "enableGLShaders = 0" esetén tudom csak lefordítani, különben leáll a fordítás hibaüzenettel.
Mellékelem az "enableGLShaders = 1" esetén keletkezett log -ot, amiben benne van a teljes fordítási környezet is.

A 2.1 alá nemsokára, ha lesz idõm, akkor elkészítem a végleges bináris csomagot és kiadom. A 2.0 alá csak akkor, ha a fenti gond megoldódik.

Addig is köszi a sok munkádat.
:bow: :bow: :bow:

Offline IstvanV

  • EP addict
  • *
  • Posts: 4806
  • OS:
  • Linux (Suse) Linux (Suse)
  • Browser:
  • Konqueror 3.5.9 Konqueror 3.5.9
    • View Profile
Re: ep128emu 2.0.7
« Reply #6 on: 2009.August.08. 12:27:52 »
Gond már csak az UHU 2.0 van, de nem tudom, hogy ez lényegbevágó -e?
Az "enableGLShaders = 0" esetén tudom csak lefordítani, különben leáll a fordítás hibaüzenettel.
Mellékelem az "enableGLShaders = 1" esetén keletkezett log -ot, amiben benne van a teljes fordítási környezet is.

Nem találom a log file-t :oops: Lehet, hogy elfelejtetted mellékelni ? :)

Mindenesetre valószínű, hogy az UHU 2.0-n régi OpenGL .h file-ok vannak. Talán lehetséges módosítani a forráskódot, hogy azokkal is működjön, de ha nem, akkor az SConstruct-ban kellene továbbfejleszteni a verzió ellenőrzést.

Offline IstvanV

  • EP addict
  • *
  • Posts: 4806
  • OS:
  • Linux (Suse) Linux (Suse)
  • Browser:
  • Konqueror 3.5.9 Konqueror 3.5.9
    • View Profile
Re: ep128emu 2.0.7
« Reply #7 on: 2009.August.08. 12:35:34 »
nem kell beerõltetnem a lua újabb verzióját sem

Bár, mint említettem, az 5.1 azért előnyösebb, ha valaki használni is akarja (az 5.0 pl. nem ismeri a hexadecimális konstansokat, ami a debuggernél hátrány). De egyelőre úgy látszik, hogy ezt a funkciót csak én használom :razz:, tehát a régi verzió, vagy akár a Lua letiltása a gyakorlatban talán mégsem jelent komoly problémát :).

Online Lacika

  • EP addict
  • *
  • Posts: 2926
  • Country: hu
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.5.2 Firefox 3.5.2
    • View Profile
    • http://www.ep128.hu
Re: ep128emu 2.0.7
« Reply #8 on: 2009.August.10. 21:33:04 »
Ezt nem is tudom, hova kellene írni:
BASIC-ből EXDOS-t hívunk, majd ESC: fekete képernyő, csak meleg reset segít. Ez Ep32 emuban is jelentkezik, EXOS 2.1, 2.3-al. EXDOS probléma lenne?

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13431
  • Country: hu
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.5.2 Firefox 3.5.2
    • View Profile
    • http://enterprise.iko.hu/
Re: ep128emu 2.0.7
« Reply #9 on: 2009.August.10. 21:43:43 »
Ezt nem is tudom, hova kellene írni:
BASIC-bõl EXDOS-t hívunk, majd ESC: fekete képernyõ, csak meleg reset segít. Ez Ep32 emuban is jelentkezik, EXOS 2.1, 2.3-al. EXDOS probléma lenne?
display text-et próbáltad már?  :)

Online Lacika

  • EP addict
  • *
  • Posts: 2926
  • Country: hu
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.5.2 Firefox 3.5.2
    • View Profile
    • http://www.ep128.hu
Re: ep128emu 2.0.7
« Reply #10 on: 2009.August.10. 22:19:38 »
display text-et próbáltad már?  :)
Igen!  :lol:

Offline Attus

  • EP addict
  • *
  • Posts: 1230
  • Country: hu
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 2.0.0.16 Firefox 2.0.0.16
    • View Profile
Re: ep128emu 2.0.7
« Reply #11 on: 2009.August.11. 13:40:27 »
Nem találom a log file-t :oops: Lehet, hogy elfelejtetted mellékelni ? :)

Mindenesetre valószínû, hogy az UHU 2.0-n régi OpenGL .h file-ok vannak. Talán lehetséges módosítani a forráskódot, hogy azokkal is mûködjön, de ha nem, akkor az SConstruct-ban kellene továbbfejleszteni a verzió ellenõrzést.

:oops:
Bocs, tényleg lemaradt, mert rohannom kellett.
Most pótolom, hátha tudod használni.  :)

Offline Attus

  • EP addict
  • *
  • Posts: 1230
  • Country: hu
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 2.0.0.16 Firefox 2.0.0.16
    • View Profile
Re: ep128emu 2.0.7
« Reply #12 on: 2009.August.11. 14:18:23 »
 :smt039
UHU 2.1 disztró számára az ep128emu-2.0.7.uhu bináris csomag letölthetõ innen.
Eddig tartott az elkészítése, ma 14:45 után érhetõ el, mar akkor frissül az ottani szerver.

(Off: Persze sok más uhu csomagom is található ugyanott. :smt024)

« Last Edit: 2009.August.11. 14:26:25 by Attus »

Offline Attus

  • EP addict
  • *
  • Posts: 1230
  • Country: hu
  • OS:
  • Linux Linux
  • Browser:
  • Firefox 2.0.0.16 Firefox 2.0.0.16
    • View Profile
Re: ep128emu 2.0.7
« Reply #13 on: 2009.August.11. 16:00:57 »
Nem tudtam kipróbálni a vinyó emulációt, mert nem tudtam követni titeket az IDE fejlesztés terén.  :oops:
Most kezdem csak beleásni magam.

Mit várhatunk el a nemes leendõ felhasználótól, ha én is így jártam?  :(
Egyelõre a csomagban a /usr/share/ep128/disk alá rakja a csomagom a tömörített képmásokat és mindössze arra utalok a mellékelt lemezek.hlp fájlocskában, hogy hogyan csatoljon a felhasználó floppy képmást unix alatt, és a vinyót képmást illetõ kérdéseivel meg keresse fel ezt a honlapot.
Nem ártana egy kis ismertetõ IDE téren a forrásban, célszerû módon angol nyelven, hogy ne csak a README, COPYING, NEWS meg az én kis lemezek.hlp fájlocskám dokumentálják a programot.
Ezen kis doc fájlocskákat a /usr/share/Packages/doc/ep128emu könyvtárba pakoltam, ahogy illik.
Egyelõre jónak tûnik az emu,

Egy bug?
:shock:
A ~/.ep128emu/config/ep128uk/EP_640k_EXOS231_EXDOS_utils.cfg ASCII konfig fájlt betöltve ERROR 248 -at üzen az EXDOS, floppi képmásoknál. exdos.ini esetén.
A :load start esetén meg ezt pofázza: EXOS error type 9248  :(

A ~/.ep128emu/config/ep128uk/EP2048k_EXOS231_EXDOS_utils.cfg jó!!! :)


« Last Edit: 2009.August.11. 16:12:06 by Attus »

Offline IstvanV

  • EP addict
  • *
  • Posts: 4806
  • OS:
  • Linux (Suse) Linux (Suse)
  • Browser:
  • Konqueror 3.5.9 Konqueror 3.5.9
    • View Profile
Re: ep128emu 2.0.7
« Reply #14 on: 2009.August.11. 19:47:26 »
:oops:
Bocs, tényleg lemaradt, mert rohannom kellett.
Most pótolom, hátha tudod használni.  :)

Ez valóban régi GL verziónak néz ki, hiányzanak a 2.x függvények :( (meglepő módon viszont van PFNGLCOMPILESHADERPROC). Tehát egyelőre marad az enableGLShaders=0, de a 2.0.8-ban majd továbbfejlesztem a verzió ellenőrzést. A régi GL verzióval fordítva nem működik a quality=4 mód (TV emuláció), amelyhez OpenGL 2.x kellene, de ennek talán nincs túl nagy jelentősége.
Esetleg a fordításhoz lehetne új fejléceket használni, de attól még a rendszeren található libGL*.so file-ok régiek maradnak, tehát ez a megoldás valószínűleg nem működne.