Welcome, Guest. Please login or register.


Author Topic: Snapshots-Images : Don't work allways ? (Read 3143 times)

Offline Vicman

  • EP fan
  • *
  • Posts: 188
  • Country: de
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.6.2 Firefox 3.6.2
    • View Profile
Snapshots-Images : Don't work allways ?
« on: 2010.June.26. 21:00:17 »
Hi all,

well, i'm back again  :oops:

I've made some other projects for the Frontend eCC & the Frontend GamesBase....
So, the time was to short for my Enterprise-Project...

Unfortunately the Head-Developer of the Frontend eCC has stopped (maybe paused) his work...
There are still many Features, i miss in eCC, therefore i've decided to start a "GameBase Enterprise - Project"
Don't know, if you know GameBase....but i think you do  ;-) (i.e. GameBase64 v.7)

I think this Project will take 3 - 6 Month before finished....maybe longer.....
But i've promissed myself to finsh it !

anyway....i need your help again :  :ds_icon_cheesygrin:

Because of the long Booting-time from EP128 (ca.20 seconds before a game is loaded), i want also use Snapshots (*.ep128s) as playable dumps,
because those "dumps" starts directly.

The problem is, not all Snapshots works fine. I.e. the Game 19-Part I......
I think this is because the game want to reload some stuff...and so, a Snaphot-Image don't work here.....right ?

Are there many games, that will not work as Snapshot ? - And How do i see it, and sort them out ?

Is it possible to reduce the "loading/booting-time" for a normal dump ? (use the dumps from http://www.ep128.hu/Ep_Games )

Here you can see an Example, starting 3D-Starfighter in the GameBase :
http://www.youtube.com/watch?v=LU5dWpCmpUQ

best regards,
Vicman




Best Multi-Frontends ;-)  emu Control Center and GameBase

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13529
  • Country: hu
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.6.4 Firefox 3.6.4
    • View Profile
    • http://enterprise.iko.hu/
Re: Snapshots-Images : Don't work allways ?
« Reply #1 on: 2010.June.26. 21:05:29 »
Is it possible to reduce the "loading/booting-time" for a normal dump ?
Use a any configuration with EXOS 2.3x, it is have a fast memory testing routine.

Offline Vicman

  • EP fan
  • *
  • Posts: 188
  • Country: de
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.6.2 Firefox 3.6.2
    • View Profile
Re: Snapshots-Images : Don't work allways ?
« Reply #2 on: 2010.June.26. 21:44:14 »
Thanks zozosoft.

But i can't find any  EXOS 2.3x_IO....for "normal" Tape-Dumps (*.com, *.trn etc...)
Only the EP_640k_EXOS231_EXDOS.cfg , but this is for dsk.img - files , right ?

Best Multi-Frontends ;-)  emu Control Center and GameBase

Offline Zozosoft

  • EP addict
  • *
  • Posts: 13529
  • Country: hu
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.6.4 Firefox 3.6.4
    • View Profile
    • http://enterprise.iko.hu/
Re: Snapshots-Images : Don't work allways ?
« Reply #3 on: 2010.June.26. 21:52:36 »
If I remember right the EXOS 2.31 EXDOS utils is also include the virtual File IO rom.

But the EP_128k_Tape_FileIO_TASMON is also contains fast memory test program.

Offline Vicman

  • EP fan
  • *
  • Posts: 188
  • Country: de
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.6.2 Firefox 3.6.2
    • View Profile
Re: Snapshots-Images : Don't work allways ?
« Reply #4 on: 2010.June.26. 21:55:15 »
thanks, i'll test it  ;-)
Best Multi-Frontends ;-)  emu Control Center and GameBase

Offline Vicman

  • EP fan
  • *
  • Posts: 188
  • Country: de
  • OS:
  • Windows XP Windows XP
  • Browser:
  • Firefox 3.6.2 Firefox 3.6.2
    • View Profile
Re: Snapshots-Images : Don't work allways ?
« Reply #5 on: 2010.June.26. 22:16:16 »
You're right, zozo  :cool:

Both works with tapes :smt026

I think the EP_128k_Tape_FileIO_TASMON is a little bit faster....so i will use this as standard.

Thanks again ! I'll post again when i have finished a beta-GameBase, or when i run again in any problems  :roll:

- Vicman


 
Best Multi-Frontends ;-)  emu Control Center and GameBase