Welcome, Guest. Please login or register.


Author Topic: MAc emulator?? (Read 14390 times)

Offline Tutus

  • EP lover
  • *
  • Posts: 534
  • Country: hu
  • OS:
  • Mac OS X 10.15 Mac OS X 10.15
  • Browser:
  • Firefox 82.0 Firefox 82.0
    • View Profile
    • Enterpress News
Re: MAc emulator??
« Reply #45 on: 2020.November.14. 16:12:00 »
Ez az én formám... nálam semmi sem működik, mindennel gond van... lásd SF3 is ... :(

Offline ergoGnomik

  • EP lover
  • *
  • Posts: 960
  • Country: hu
  • Stray cat from Commodore alley
  • OS:
  • Windows NT 6.3 Windows NT 6.3
  • Browser:
  • Firefox 78.0 Firefox 78.0
    • View Profile
Re: MAc emulator??
« Reply #46 on: 2020.November.14. 16:18:03 »
A Mac egy külön állat, Unix alapú[]/i
Hát ezt azért inkább ne mondjad egy igazi Unixosnak, mert furcsán fog rád nézni és kiröhög, vagy elküld melegebb éghajlatra. Maradjunk annyiban, hogy az alapjai Unix-szerűek és tényleg külön állatok az Apple-féle *OS-ek.

Offline Tutus

  • EP lover
  • *
  • Posts: 534
  • Country: hu
  • OS:
  • Mac OS X 10.15 Mac OS X 10.15
  • Browser:
  • Firefox 82.0 Firefox 82.0
    • View Profile
    • Enterpress News
Re: MAc emulator??
« Reply #47 on: 2020.November.14. 18:30:23 »
Na, hátha valaki megfejti:

A teljes library csomag telepítve lett valamint a Homebrew is.

Aztán egyenként kért .dylib fájlokat, melyeket kézzel terminalon keresztül telepítettem Tango utasításai szerint.
Most itt tartunk:

  Library not loaded: /usr/local/opt/lua/lib/liblua.5.3.dylib
  Referenced from: /private/var/folders/*/ep128emu.app/Contents/MacOS/ep128emu
  Reason: image not found

Offline geco

  • EP addict
  • *
  • Posts: 5763
  • Country: hu
  • OS:
  • Linux Linux
  • Browser:
  • Chrome 86.0.4240.99 Chrome 86.0.4240.99
    • View Profile
Re: MAc emulator??
« Reply #48 on: 2020.November.14. 18:51:07 »
add ki a kovetkezo parancsot: brew switch lua 5.3
elmeletileg ha nem talalja,kiirja, hogy milyen verzioid vannak.

Offline Tutus

  • EP lover
  • *
  • Posts: 534
  • Country: hu
  • OS:
  • Mac OS X 10.15 Mac OS X 10.15
  • Browser:
  • Firefox 82.0 Firefox 82.0
    • View Profile
    • Enterpress News
Re: MAc emulator??
« Reply #49 on: 2020.November.14. 18:56:37 »
add ki a kovetkezo parancsot: brew switch lua 5.3
elmeletileg ha nem talalja,kiirja, hogy milyen verzioid vannak.
lua's installed versions: 5.3.5_1

Offline geco

  • EP addict
  • *
  • Posts: 5763
  • Country: hu
  • OS:
  • Linux Linux
  • Browser:
  • Chrome 86.0.4240.99 Chrome 86.0.4240.99
    • View Profile
Re: MAc emulator??
« Reply #50 on: 2020.November.14. 18:57:56 »
akkor switchelj arra: brew switch lua 5.3.5_1
es probald inditani az emut

Offline Tutus

  • EP lover
  • *
  • Posts: 534
  • Country: hu
  • OS:
  • Mac OS X 10.15 Mac OS X 10.15
  • Browser:
  • Firefox 82.0 Firefox 82.0
    • View Profile
    • Enterpress News
Re: MAc emulator??
« Reply #51 on: 2020.November.14. 20:05:57 »
Következő :)

Dyld Error Message:
  Library not loaded: /usr/local/opt/portaudio/lib/libportaudio.2.dylib
  Referenced from: /private/var/folders/*/ep128emu.app/Contents/MacOS/ep128emu
  Reason: image not found

Offline tango

  • Newbie
  • Posts: 8
  • Country: hu
  • OS:
  • Mac OS X 10.15.7 Mac OS X 10.15.7
  • Browser:
  • Safari 13.1.3 Safari 13.1.3
    • View Profile
Re: MAc emulator??
« Reply #52 on: 2020.November.14. 20:12:25 »
brew install portaudio

Offline Tutus

  • EP lover
  • *
  • Posts: 534
  • Country: hu
  • OS:
  • Mac OS X 10.15 Mac OS X 10.15
  • Browser:
  • Firefox 82.0 Firefox 82.0
    • View Profile
    • Enterpress News
Re: MAc emulator??
« Reply #53 on: 2020.November.15. 17:35:34 »
Még volt egy ilyen lib install, és most MEGY!
Viszont baromi lassan üzemel. Mit kell állítanom?
Mintha emlékeznék valami beállításra amitől ez megjavul... Előző MAC-es emuknál írta valaki, de elfelejtettem :(

Online Trefe

  • Beginner
  • *
  • Posts: 46
  • Country: hu
  • OS:
  • Windows NT 10.0 Windows NT 10.0
  • Browser:
  • Firefox 82.0 Firefox 82.0
    • View Profile
Re: MAc emulator??
« Reply #54 on: 2020.November.15. 17:38:23 »
Ezt gyakran hang vagy video (OpenGL) driver probléma okozza. Tehát érdemes szoftveres video móddal próbálkozni (ha ez nem volt már az), vagy OpenGL esetén a single/double buffered mód helyett a másikat beállítani. A hang letiltása (vagy "none" eszköz választása) eredményez javulást? Ha igen, akkor itt is lehet próbálkozni más beállításokkal, másik kimeneti eszköz/API választásával, a pufferek száma és latency módosításával/növelésével, vagy fordításnál másik PortAudio verzióval.

Az emulátor egyébként a MIDI-s beta verzió?

A Windowsos .exe futtatására használható Wine is, legalábbis Linuxon elfogadhatóan működik így.

Offline Tutus

  • EP lover
  • *
  • Posts: 534
  • Country: hu
  • OS:
  • Mac OS X 10.15 Mac OS X 10.15
  • Browser:
  • Firefox 82.0 Firefox 82.0
    • View Profile
    • Enterpress News
Re: MAc emulator??
« Reply #55 on: 2020.November.15. 17:39:18 »
Köszi, meg is van!
Az emulátorban Options -> Sound -> Configure menüben a Latency csúszkát minimumra kell állítani (bal szélre, akkor 5 lesz az értéke).
És láss csodát, így tökéletesen működik!

Köszönöm mindenkinek a segítséget! :)
« Last Edit: 2020.November.15. 17:57:18 by Tutus »